Fordmods Logo

EF Trans trouble 


Page 1 of 1 [ 2 posts ] 

 Post subject: EF Trans trouble
Posted: Thu Feb 17, 2011 11:19 pm 
Parts Gopher

Posts: 77

Joined: 22nd Nov 2010

Gallery: 1 images

Ride: EF Fairmont

Location: Auckland
New Zealand

My EFII Fairmont Wagon's done 188000km.

Sometimes (most of the time) when cold it will be in say 2nd gear at 30km/h and it won't slip the torque converter it will be in like lockup mode so it has no power. If you put your foot right down it will all of a sudden start to slip (as it should) and take off normally. It seems to do this particularly when its cold.... It will do it in 3rd as well. Apart from that it changes smoothly and doesn't shudder.

I'm not sure what it is, could it be the torque converter?

 Post subject: Re: EF Trans trouble
Posted: Fri Feb 18, 2011 8:06 pm 
Fordmods Newbie

Age: 50

Posts: 16

Joined: 22nd Jan 2011

Ride: bf xr6 and xr fg 50th anniversay

Location: orange
NSW, Australia

it sounds like it has a bloked trans filter go and buy a trans kit and change the filter and oil tq95 or 95le trans oil
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 3:51 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names