Fordmods Logo

EL XR6 Squeak 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EL XR6 Squeak
Posted: Thu Aug 24, 2006 5:35 pm 
Stock as a Rock
Offline
User avatar

Posts: 146

Joined: 2nd Apr 2006

Gallery: 3 images

Ride: EL XR6

Location: Otago
New Zealand

I have a very annoying squeak down the rear of my car somewhere that squeaks everytime i go over the smallest bump. I know this has been covered before i have done a search and covered the topic but all i can see is theorys being thrown round does anybody actually know what causes this problem????

Nick
Top
 Profile  
 
 
Posted: Thu Aug 24, 2006 5:38 pm 
Tyre Shredder
Offline

Age: 30

Posts: 321

Joined: 28th Apr 2006

Gallery: 5 images

Ride: EF Fairmont

Location: gold coast
QLD, Australia

man i got that same problem it drives me fuken nuts

 

_________________

Piss On Holden!!!!
EF Fairmont argon silver, ultralows,koni adjustables,pioneer stereo, 19 inch vault kaotiks,

Top
 Profile  
 
 
Posted: Thu Aug 24, 2006 6:58 pm 
Stock as a Rock
Offline
User avatar

Posts: 146

Joined: 2nd Apr 2006

Gallery: 3 images

Ride: EL XR6

Location: Otago
New Zealand

Come on fellas surely someone else has had this problem!!!
Top
 Profile  
 
 
Posted: Thu Aug 24, 2006 11:44 pm 
Fordmods Newbie
Offline
User avatar

Age: 46

Posts: 7

Joined: 8th Jul 2006

Ride: EF V8 & BA XR6

Location: perth
WA, Australia

i have found this problem before
i used to work for a suspension shop

if your upper arms have been removed and had other placed in, are they in the correct hole, the base of the arm rubs on the diff housing,

have you had the shocks replaced and havent been tightened and alligned correctly on the top, has the bolt on the bottom of the shock 100% tight, most shocks have paint on the lower mount and when the paint evently cracks of, it rubs

have your link pin rubbers split or moved, the pin might be rubbing on the mount

while your there check your lower bushes and watts linkage
Top
 Profile  
 
 
Posted: Fri Aug 25, 2006 3:43 pm 
Fordmods Newbie
Offline
User avatar

Age: 46

Posts: 7

Joined: 8th Jul 2006

Ride: EF V8 & BA XR6

Location: perth
WA, Australia

sorry guys i forgot to mention

the upper arms on a xr have a small cut out in them, its just before the rear bush, its a half circle, if they are not there you have the wrong arms

be careful with some after market arm, they dont have the cut out
Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 11:24 am 
Smokin em up
Offline
User avatar

Age: 33

Posts: 291

Joined: 5th Nov 2004

Ride: EL GT - T2 TS50

Location: Cairns
QLD, Australia

I had this squeak too and after searching the forums and everyone saying its bushes (and in some cases I'm sure it is) I have found in my case that it was the rear brake pads. normally when brakes squeak its when you apply them, but not these they seem to have been jumping around between the caliper and disc while driving, giving off a really annoying noise over the smallest bump or reflector etc.

http://home.austarnet.com.au/preditor/pics/dsc05251.jpg

http://home.austarnet.com.au/preditor/pics/dsc05252.jpg

The pics are big so you can see the detail, all I did was stick some gasket paper between the mount bracket and pad to separate the metal on metal contact and it shut them up.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 3:44 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names