Fordmods Logo

experiences with rvo automatics 800 hp 4l60e gearbox 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: experiences with rvo automatics 800 hp 4l60e gearbox
Posted: Mon Mar 30, 2015 8:43 am 
Fordmods Newbie
Offline

Age: 43

Posts: 2

Joined: 30th Mar 2015

Ride: 03 xr6turbo

Location: Booie
QLD, Australia

I have gone through 4 of these boxes frying all within 10 km as soon as boost comes on had big turbo running a moderate tune about 550 hp at tyres .. any others out there who have similar stories lets hear them .....
Top
 Profile  
 
 
 Post subject: Re: experiences with rvo automatics 800 hp 4l60e gearbox
Posted: Wed Apr 01, 2015 5:58 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

I take it that they have been fitted with a heavy cast alloy pan ???....and a large ATF cooler ???

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: experiences with rvo automatics 800 hp 4l60e gearbox
Posted: Wed Apr 08, 2015 2:06 am 
Fordmods Newbie
Offline

Age: 45

Posts: 6

Joined: 3rd Apr 2015

Ride: Ford/BA XR6T

Location: Goldcoast
QLD, Australia

Geez,
I wanna know how you were puttin out that much HP,mine is
about 430 at the back wheels and its a fair bit of fun?
Top
 Profile  
 
 
 Post subject: Re: experiences with rvo automatics 800 hp 4l60e gearbox
Posted: Wed Apr 08, 2015 5:08 pm 
Fordmods Newbie
Offline

Age: 43

Posts: 2

Joined: 30th Mar 2015

Ride: 03 xr6turbo

Location: Booie
QLD, Australia

Falcon YEL-57 - Feature Cars Australia this is some pics from a few years ago before putting a 1200 hp nizpro motor , bigger intercooler , turbo and process west plenum and 1600 cc injectors and was running a powerglide with transbrake in which never had a problem until i tried these gearboxes , saw power figures of 800 at tyres on pump fuel , 1000 at tyres on race fuel but was running a moderate tune for street 550 at tyres ..... ran a 10.03 down strip ...... motor and turbo detonated first drive back after number 4 , getting it back from rvo ute has been off road for 2 1/2 years from fitting first box ....not happy worst decision i have ever made should have stuck with the indestructible 2 speed if you go onto ebay and look at rvo 4l60e 800 hp xr6turbo you will see a pic of my engine bay in which i have asked him to remove for i want nothing to do with that company ..... i just want to know if there are any others out there i know there are as i have spoken to a couple of you who have also destroyed these boxes with less power than mine was making
Top
 Profile  
 
 
 Post subject: Re: experiences with rvo automatics 800 hp 4l60e gearbox
Posted: Sun Jul 19, 2015 10:53 am 
Fordmods Newbie
Offline

Age: 38

Posts: 1

Joined: 19th Jul 2015

Ride: Ford XR6T

Location: Mackay
QLD, Australia

I too have had similar problems. We purchased a 1000hp rated 4l60e transmission. I drove the car about 7km, the transmission failed and we only had the 450rwhp engine in it at that time. Had to get the car put on a tilt tray to be taken back to our workshop. We sent the transmission back for warranty and they blamed it on the incorrect flexplate or converter being used, he must have forgotten they supplied both of those parts with the box. 3years later I still have no transmission and over $6000 out of pocket.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names