Fordmods Logo

help!! loud snapping sound from under car!! 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: help!! loud snapping sound from under car!!
Posted: Thu Oct 19, 2006 8:12 am 
Fordmods Newbie
Offline

Age: 30

Posts: 14

Joined: 2nd Jul 2006

Gallery: 1 images

Ride: ED XR6

Location: Mansfield
VIC, Australia

Ok my xr6 has done alot of burnouts lately :) and now after all that my diff cones are gone and sometimes when the auto shifts from first to second under harsh driving.... i hear this SNAP!! i hav no idea wot it is..

it happened in my old xe ex cop car (nice r.i.p.) :( and it was an engine mount. but in the ed its not!! HELP
Top
 Profile  
 
 
Posted: Thu Oct 19, 2006 9:17 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Stop doing burnouts all the time lol

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Thu Oct 19, 2006 12:34 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

Trans mount could be brocken. Check Driveline for any obvious damage.
Top
 Profile  
 
 
Posted: Thu Oct 19, 2006 2:08 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 529

Joined: 23rd Aug 2006

Ride: 2000 AU Fairmont

Location: Perth
WA, Australia

could be uni joints or the spider gears in your diff could be f**k...

im getting the same thing happening, but mine doesnt happen when shifting, happens whenever it wants, sometimes under sever wheel spin and sometimes when going 5km/h into a driveway... weird

 

_________________

Image

Top
 Profile  
 
 
 Post subject: mmmmm
Posted: Thu Oct 19, 2006 2:19 pm 
Stock as a Rock
Offline

Age: 31

Posts: 115

Joined: 10th Jan 2005

Ride: Falcon

Location: Perth
WA, Australia

My xf did this when she was still on the road, eded up being the read trailing arm bushes, they were loosened off, could be from heat... not sure, anyway tighted all rear bushes in diffmounting area.

PS make sure u tighted under the cars load.

Muff
Top
 Profile  
 
 
Posted: Thu Oct 19, 2006 3:25 pm 
Parts Gopher
Offline
User avatar

Age: 43

Posts: 72

Joined: 9th Sep 2006

Ride: 2010 g6e turbo

Location: Craigmore
SA, Australia

my eb started to make a serious clunk noise when it dropped back a gear under hard accelleration, no noise under normal conditions. this went on for about two months until it revealed itself. a clutch in the tranny packed it in required a full recon was not cheap.

 

_________________

2010 G6E TURBO

Top
 Profile  
 
 
Posted: Thu Oct 26, 2006 9:43 pm 
Parts Gopher
Offline

Posts: 90

Joined: 24th Feb 2006

Location: Melbourne
VIC, Australia

i also have had this problem when shifting first to second.. or doing a roll back im guessing its my diff gears snapping lmao
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 9:10 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names