Fordmods Logo

Knocking sound when turning 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Knocking sound when turning
Posted: Tue Jan 09, 2007 11:05 pm 
Stock as a Rock
Offline

Age: 48

Posts: 165

Joined: 9th Jan 2007

Ride: 75th AUII Ghia

Location: Sydney
NSW, Australia

Like something in front suspension needs to be checked - got no idea - maybe ball joint or something pls help - also steering is very hard - struggle with steering even when car starts to move
Top
 Profile  
 
 
Posted: Tue Jan 09, 2007 11:22 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 967

Joined: 8th Nov 2004

Gallery: 7 images

Ride: TE50

Location: Brisvegas
QLD, Australia

hahaha, i used to have the same problem....till i realised it was my mag wheel adapter in the glove box (never hurts to check the simple things)

seriously tho, what car is it? maybe the bushes are gone (if its an older car...or ex taxi)

 

_________________

Formerly SpuDEF

Top
 Profile  
 
 
Posted: Tue Jan 09, 2007 11:26 pm 
Stock as a Rock
Offline

Age: 48

Posts: 165

Joined: 9th Jan 2007

Ride: 75th AUII Ghia

Location: Sydney
NSW, Australia

96 EL Futura - all is OK used to be some companys managers car well taken care and it goes well but Im no mechanic - I can build you a server but not cars
Top
 Profile  
 
 
Posted: Wed Jan 10, 2007 12:45 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

Thread moved

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
 
Posted: Wed Jan 10, 2007 12:52 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 948

Joined: 3rd Mar 2006

Gallery: 11 images

Ride: BA XR6 Ute

Location: Brisbane - Perth
QLD, Australia

we just had similar problem with my mates, so we took the front steering knuckles off and replaced both upper and lower ball joints. while we were doin ti we diod all the suspension and the tie rod ends. something in there was the cause, cause it stopped. my money was on the ball joints, the lack of rubber boot on the uppers was a dead give away that they were knackered

 

_________________

nascentes morimur

Top
 Profile  
 
 
Posted: Wed Jan 10, 2007 1:47 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 967

Joined: 8th Nov 2004

Gallery: 7 images

Ride: TE50

Location: Brisvegas
QLD, Australia

yeh we had the same problem with our old XF, replaced all the ball joints and tie rod ends and she drove like it was on rails

 

_________________

Formerly SpuDEF

Top
 Profile  
 
 
Posted: Wed Jan 10, 2007 2:25 pm 
Stock as a Rock
Offline

Age: 48

Posts: 165

Joined: 9th Jan 2007

Ride: 75th AUII Ghia

Location: Sydney
NSW, Australia

thanks much guys appreciate it - got better idea now to discuss with shop person like I know what Im talking about hehe
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Fri Dec 15, 2017 8:19 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names