Fordmods Logo

No brakes!! 

 

Page 1 of 2 [ 20 posts ] Go to page 1, 2  Next

 
 Post subject: No brakes!!
Posted: Mon Jun 20, 2011 2:04 am 
Parts Gopher
Offline

Age: 25

Posts: 92

Joined: 13th May 2010

Ride: F6 Typhoon

Location: North West Sydney
NSW, Australia

So there i was driving down the great western highway at 80kmh in wet weather wondering why i suddenly had a rock hard brake pedal with no warning whatsoever. Crawled home to investigate and:

Attachment:
File comment: Booster 01
booster 1.jpg
booster 1.jpg [ 192.09 KiB | Viewed 23 times ]


Attachment:
File comment: Booster 2
booster 2.jpg
booster 2.jpg [ 119.13 KiB | Viewed 40 times ]


Im feeling lucky :shock: but how do i know this wont happen again? is this some sort of common occurence? i have a replacement booster in there of course coutesy of pick and payless, but i want to figure out what caused it so that i and anyone else can prevent it hapening again!! it goes without saying break faliure is downright dangerous.

 

_________________

F6 Typhoon Silhouette with Dark Argent rims, build P0001. Stock as a rock and staying that way.

Now sold :( Cobalt blue EF XR6, Pacemaker 4499s, 2.5" redback catback, intake, head shaved, wade 977b, crow valve springs, pedders suspension.

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 8:47 am 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 3355

Joined: 10th Jan 2010

Gallery: 8 images

Ride: EL XR6

Location: albion park, wollongong
NSW, Australia

Same thing happened to me in my Ef. It's a common problem. Always cracks at 3 o'clock . I had to drive around with s**t brakes for a day or 2 until I could get to the wreckers . I used the handbrake to stop. My brakes still worked as mine was only a small crack and I patched it up.

 

_________________

El XR6 Turbo
Dark Agents,Sunroof, bilstein shocks, 6000k HIDS, 329 mm slotted rotors, twin pot calipers , Climate Control, GarrettT04 turbo,log manifold, crow turbo cam, microtech lt10c, 42lb injectors , 044, surge tank , T56 , rebuilt bottom end , alloy plenum .

Aiming for 300 rwkw

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 9:28 am 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

Replace it with an AU2 Booters and Master, Ploblem solved.

They all do it. They fail from heat and are more prone if you have extractors. You could also look at sheilding them with soem sort of heat wrap etc.

I have been through 6 in total on my fairmont, and changed to AU2 recently. Be advised, it is not a bolt on job, you need to carefully measure and drill new holes into your firewall.

Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 9:52 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

or go with an ed steel booster, only need to drill 2 holes...
Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 10:59 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

It's not a common problem.

It's really a problem of your/our own doing. :wink:

I see you have pacies... Does it have a proper heat shield over it? I'm assuming not, hence the crack in the spot where it gets the hottest, and in line with where the bolts clamp down and hold the unit together. Only seems to happen to those with unshielded exhausts.

I'd be replacing the cruise control backup pressure switch, as that will probably be next.
Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 12:44 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 3355

Joined: 10th Jan 2010

Gallery: 8 images

Ride: EL XR6

Location: albion park, wollongong
NSW, Australia

Mine cracked when I had stock exhaust on , with heat shield

 

_________________

El XR6 Turbo
Dark Agents,Sunroof, bilstein shocks, 6000k HIDS, 329 mm slotted rotors, twin pot calipers , Climate Control, GarrettT04 turbo,log manifold, crow turbo cam, microtech lt10c, 42lb injectors , 044, surge tank , T56 , rebuilt bottom end , alloy plenum .

Aiming for 300 rwkw

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 9:26 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Also add a bracket from the end of the booster to the strut tower or similar,

Not only will it stiffen up the brake feel, but also reduce the stress the plastic booster gets when you hit the pedal.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 9:50 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Love my ED all steel dual diaphragm booster... Nice improvement over std ED booster...

Krytox, will that make of a difference to an ED with a steel booster? Is there that much firewall flex?

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 9:54 pm 
Getting Side Ways
Offline

Age: 29

Posts: 4182

Joined: 30th May 2005

Ride: 1993 EB XR8

Location: BrisVegas
QLD, Australia

uniacidz wrote:
I have paccies but have a heat shield.

It does dramatically reduce the temperature insider the engine bay

I have nothing to compare it to, but I have a modded heatshield over my 4480's in my NC.

 

_________________

ILL60 - EF XR8, Sunroof, Ticky Kit, 19x8.5/19x11 TE37's, 347, AFr185's, TFS BoxRcustom converter, Hurst Quarterstick, huge billet cam.

51TER - DL LTD. Stock.

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Mon Jun 20, 2011 10:18 pm 
Getting Side Ways
Offline
User avatar

Age: 27

Posts: 1998

Joined: 31st Dec 2007

Gallery: 9 images

Ride: xc wag's, tnklane wag's

Location: Munruben
QLD, Australia

Potentially 14 yr old part I've had 3 faulty ones one failed I replaced it with a "second hand one", It failed, a few months later I purchased another second hand one, this was already faulty, so I tried again with second handy and in the near future I got rid of the car, intended to anyway, hence using second hand.

as mentioned no guarantee, but you would have much more chance of it not failing putting in a new part, not a x years old part.

mine never failed that substantially, whether nursing it home effected it, I personally was lucky enough to be near enough home to just tilt tray it.

 

_________________

Signature removed by moderator.signature must not exceed 120x500 pixles

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Tue Jun 21, 2011 3:43 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

had it happen to me twice. Lucky enough I only found the issue while backing out the driveway, not doing speed.

Extractors will speed up the rate they die as the heat shield won't be there, however, I think I can track mine down to being caused by ethanol. First was just after a service where injector cleaner was used & the other I had a tank of E10 in it. The timing was also fairly retarded which has now been fixed.

maybe it was ethanol fumes weakening the plastic, extra heat, chance? either way, I've covered the booster in that silver heat tape just to keep it cool. even if it does split again, it needs to rip the tape apart

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Tue Jun 21, 2011 9:29 am 
Getting Side Ways
Offline

Age: 29

Posts: 4182

Joined: 30th May 2005

Ride: 1993 EB XR8

Location: BrisVegas
QLD, Australia

Ehanol caused it? Thats the biggest load of crap! I'd call it plastic fatigue, no other causes.

 

_________________

ILL60 - EF XR8, Sunroof, Ticky Kit, 19x8.5/19x11 TE37's, 347, AFr185's, TFS BoxRcustom converter, Hurst Quarterstick, huge billet cam.

51TER - DL LTD. Stock.

Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Tue Jun 21, 2011 12:46 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

uniacidz wrote:
^ ethanol can also cause pod filters to catch on fire


how???

if ethanol can set a pod on fire so can petrol...lpg would have a better chance of setting a pod on fire.
you would need one huge a** intake backfire to set a pod on fire..
Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Tue Jun 21, 2011 4:39 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

uniacidz wrote:
TROYMAN wrote:
uniacidz wrote:
^ ethanol can also cause pod filters to catch on fire


how???

if ethanol can set a pod on fire so can petrol...lpg would have a better chance of setting a pod on fire.
you would need one huge a** intake backfire to set a pod on fire..


Was a joke :shock:

Cos coppers say that pods can catch fire etc etc


ok, for a second i thought you lost your mind...lol
Top
 Profile  
 
 
 Post subject: Re: No brakes!!
Posted: Tue Jun 21, 2011 8:19 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

67RCE wrote:
Ehanol caused it? Thats the biggest load of crap! I'd call it plastic fatigue, no other causes.


well as I say, I used it twice & blew up 2 boosters. heat or something. wont be putting ethanol or injector cleaner in again

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 20 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names