Fordmods Logo

Noisy Front Suspension 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Noisy Front Suspension
Posted: Sun Jul 09, 2006 9:10 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 8th Mar 2006

Location: Greensborough
VIC, Australia

Gday all.
My EF has developed really noisy front shockers over the past few weeks. Every speed bump is painful on the ears. Just crusing around the streets is fine, but any sort of noticable bump is accompanied by loud sqeaking noises. Its really starting to annoy me. Does anyone have any idea how i can fix this problem without spending alot of dosh? I havnt tried anything so far, thought i would ask around here first.
Thanks
Top
 Profile  
 
 
Posted: Mon Jul 10, 2006 1:06 am 
Getting Side Ways
Offline

Age: 28

Posts: 1135

Joined: 27th Oct 2005

Gallery: 3 images

Location: SA
SA, Australia

Lol when u find out whats wrong with your u can tell me what to fix as mine has been doing it for nearly 6000km an only had the shocks an springs for just over 10,000km
Top
 Profile  
 
 
Posted: Mon Jul 10, 2006 6:45 pm 
Getting Side Ways
Offline

Posts: 790

Joined: 18th Mar 2005

Gallery: 4 images

Location: Adelaide
SA, Australia

Bloody hell! I thought the dreaded Falcon squeaks only hit XR - XC Falcons... Every Falcon in this range I ever owned squeaks over bumps...the grease nipples on the spring towers were always inadequate on these, dunno if thats relevant to later falcons...

Lately I've taken to dousing the underside of the suspension with wd 40- I know, rough as guts!!!! but it shuts it up for about 6 months.....

 

_________________

351 4V XB Coupe running LPG

Top
 Profile  
 
 
Posted: Tue Jul 11, 2006 3:55 pm 
Stock as a Rock
Offline

Posts: 124

Joined: 2nd Apr 2005

Ride: Fairmont

Location: Melbourne
VIC, Australia

Bushes! I replaced my whole suspension system last month and the condition of the front bushes was shocking. Mine was squeeking (bushes) and hissing (leaking shocks) all the time.

 

_________________

V8 Windsor here we come.....

Top
 Profile  
 
 
Posted: Tue Jul 11, 2006 5:11 pm 
Getting Side Ways
Offline

Age: 40

Posts: 2015

Joined: 9th Mar 2005

Gallery: 4 images

Ride: Territory TX AWD & AUII XLS EGAS

Location: East Kurrajong
NSW, Australia

Could be a number of things ... check for play in the steering rack ... it could be a stuffed rack ... also ball joints. Also bushes as well. Could be a number of different things.

Go for one of those suspension/safety checks ... they will tell you what it is that is causing the issue ... then you can get it fixed once you know what it is.

 

_________________

04 Territory TX AWD - Winter White - optioned up
06 Falcon BFII XLS ute EGAS - Winter White - EGA-54D Version 2

Top
 Profile  
 
 
Posted: Tue Jul 11, 2006 9:52 pm 
Getting Side Ways
Offline

Age: 34

Posts: 756

Joined: 21st Nov 2005

Gallery: 25 images

Ride: 1999 AU futura

Location: griffith
NSW, Australia

Now your squeeking crunching noise's could be one of the following but i would suggest replacement of all front bushes if need be.But it could be your upper control arms bushes,or most common are the castor rubbers or could be your swaybar D rubbers which tend to be neglected but are noisey when worn.You can take the D rubbers out and grease them up and see if that stops your noise but if not well id suggest to replaced the whole front bushes.More than likely there are all worn.

 

_________________

COMING SOON,XD WITH A TURBO...CLEVO STYLE

Top
 Profile  
 
 
Posted: Tue Jul 11, 2006 11:19 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

This may seem too simple to be true but i had a similar sound and looked everywhere, i thought it was bushes or even shocks. Just by chance when i had it jacked up i noticed that the sway/stabiliser bar had been rubbing on the chassis as it bends around toward the lower control arm. I replaced the D bushes and had to grind away about 4mm where it was rubbing. Dont worry it wasnt structual where it was removed!
Top
 Profile  
 
 
Posted: Wed Jul 12, 2006 5:38 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 8th Mar 2006

Location: Greensborough
VIC, Australia

Thanks guys, ill book it in for a suspension safety check asap to find out exactly what the problem is. Ill test out the ED40 idea in the mean time haha. Ill keep you posted. If anyone has any other idea, please let me know =D
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 2:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names