Fordmods Logo

power steering 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: power steering
Posted: Wed Jan 05, 2005 12:25 am 
Parts Gopher
Offline

Age: 32

Posts: 92

Joined: 8th Nov 2004

Ride: ed futura

Location: perth
WA, Australia

my power steering is sorta on and off if it wants to work as of 1hr ago.

could it be the fluid. its 2 dark 4 me 2 check it till the morning.

 

_________________

www.thepurplecircle.com
original member.

Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 2:53 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2449

Joined: 5th Nov 2004

Ride: Falcon EB-s

Location: Manjimup
WA, Australia

Well, check the fluid by torch, or even better, a conveniently placed streetlight, or headlight? If its not the level of fluid, it may be a power steering pump, or possibly rack.

 

_________________

The problem with America is stupidity. I'm not saying there should be a capital punishment for stupidity, but why don't we just take the safety labels off of everything and let the problem solve itself?
Image

Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 3:08 am 
Parts Gopher
Offline

Age: 32

Posts: 92

Joined: 8th Nov 2004

Ride: ed futura

Location: perth
WA, Australia

yeh but its easyer 2 sit at the comp and post s**t. lol.
fuk im slack

 

_________________

www.thepurplecircle.com
original member.

Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 1:32 pm 
Parts Gopher
Offline

Age: 32

Posts: 92

Joined: 8th Nov 2004

Ride: ed futura

Location: perth
WA, Australia

ok just went and check it all.

fluids fine, no leaks and it is still a liquid.

any way of picking if its the pump or the rack?

 

_________________

www.thepurplecircle.com
original member.

Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 1:37 pm 
Parts Gopher
Offline

Age: 32

Posts: 92

Joined: 8th Nov 2004

Ride: ed futura

Location: perth
WA, Australia

and the pullys/ belt is fine

 

_________________

www.thepurplecircle.com
original member.

Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 1:56 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

does teh pump make grindy noises when your are turning the wheel
and is your pump belt tight?

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Thu Jan 06, 2005 1:51 am 
Parts Gopher
Offline

Age: 32

Posts: 92

Joined: 8th Nov 2004

Ride: ed futura

Location: perth
WA, Australia

yeh belts are all right (no slipping or ware)
and theres no noise, which is whats confusiong me.
im thinking its a bearing or seal thats putting resistance on the colum and making it harder 2 turn.

 

_________________

www.thepurplecircle.com
original member.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:49 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names