Fordmods Logo

s**t me badly 


Page 1 of 1 [ 2 posts ] 

 Post subject: s**t me badly
Posted: Tue Dec 02, 2008 12:11 pm 
Fordmods Newbie

Age: 37

Posts: 12

Joined: 5th Feb 2008

Ride: BA XT

Location: Melbourne
VIC, Australia

Hi all ive got abit of a problem ive got Ba xt 03 and when im driving on the freeway at 100 and take my foot of the gas theres like 1 slight bang coming from the rear end of the car cant tell if its the diff or tail sharft .has anybody had this problem before. :?:
Posted: Tue Dec 02, 2008 1:11 pm 
Getting Side Ways
User avatar

Age: 27

Posts: 811

Joined: 30th Aug 2007

Gallery: 2 images

Ride: AU Fairmont

Location: Canberra
ACT, Australia

All I can suggest is change diff oil. I think it gets overlooked by too many people when considering what they need to do to maintain a car's reliability.



Auto '99 AU Fairmont
Pacemaker 4499's, Hi-flow cat, 2.5" Redback catback
K & N Filter, NGK Plugs
Lows all 'round, Monroe's in the front, GSR's in the rear
Pioneer H/U
Tickford Bodykit
30mm + 22mm adjustable sway bars.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 12:19 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names