Fordmods Logo

speedo is out 10 km 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: speedo is out 10 km
Posted: Sun May 23, 2010 11:16 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 14

Joined: 4th Feb 2006

Ride: ef falcon

Location: melbourne
VIC, Australia

hey guys i recently put a fairmont ghia speedo in my ef gli its got a ef xr6 manual in it and 345 diff ratio the standard speedo used to show 100 kmh when the revs where at 2000 rpm in 5th now with the new speedo at 2000rpm the speedo says im doing 90kmh does anyone no how i can fix this or re calibrate it? cheers
Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Sun May 23, 2010 11:36 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 580

Joined: 9th Sep 2009

Ride: EF Falcon GLi

Location: ADELAIDE
SA, Australia

Bigger rims :twisted:

 

_________________

Now, I've got a message for all the other drivers out there. If you smell a delicious, crispy smell after the race, it's not your tailpipe. It's just a little of Shake...and Bake!
SHAKE AND BAKE

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 12:42 am 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

change the speedo gear, use the search

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 2:53 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 580

Joined: 9th Sep 2009

Ride: EF Falcon GLi

Location: ADELAIDE
SA, Australia

Krytox wrote:
change the speedo gear, use the search

Thats the litle yellow thing hay?

 

_________________

Now, I've got a message for all the other drivers out there. If you smell a delicious, crispy smell after the race, it's not your tailpipe. It's just a little of Shake...and Bake!
SHAKE AND BAKE

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 8:45 pm 
Getting Side Ways
Offline
User avatar

Posts: 659

Joined: 14th Apr 2006

Ride: EF Fairmont Sedan

Power: 180 rwkw

Location: Ferntree Gully
VIC, Australia

Click the resources Tab and look in there

Or click here documents.php?d=30

 

_________________

PROEF 13.46 @ 105.78mph - 1994 Ford Fairmont EF NA 6cyl Man 3.9 diff Sedan
Stock Fuel Pump, 29lb Injectors, JMM Street Series Headers, 2.5" Exhaust, 205rwkw

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 10:42 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 14

Joined: 4th Feb 2006

Ride: ef falcon

Location: melbourne
VIC, Australia

hey guys thanks for helping here but the thing i dont get is how the gli cluster was spot on with the speed and now i put the ghia cluster in its out now and i haven't changed wheels or anything
Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:13 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 580

Joined: 9th Sep 2009

Ride: EF Falcon GLi

Location: ADELAIDE
SA, Australia

glendogg wrote:
hey guys thanks for helping here but the thing i dont get is how the gli cluster was spot on with the speed and now i put the ghia cluster in its out now and i haven't changed wheels or anything

Maybe it was the GLI that was broke... :shock:

 

_________________

Now, I've got a message for all the other drivers out there. If you smell a delicious, crispy smell after the race, it's not your tailpipe. It's just a little of Shake...and Bake!
SHAKE AND BAKE

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:24 pm 
Getting Side Ways
Offline

Age: 29

Posts: 4182

Joined: 30th May 2005

Ride: 1993 EB XR8

Location: BrisVegas
QLD, Australia

ford-racer46 wrote:
glendogg wrote:
hey guys thanks for helping here but the thing i dont get is how the gli cluster was spot on with the speed and now i put the ghia cluster in its out now and i haven't changed wheels or anything

Maybe it was the GLI that was broke... :shock:

English please?

 

_________________

ILL60 - EF XR8, Sunroof, Ticky Kit, 19x8.5/19x11 TE37's, 347, AFr185's, TFS BoxRcustom converter, Hurst Quarterstick, huge billet cam.

51TER - DL LTD. Stock.

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:28 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 580

Joined: 9th Sep 2009

Ride: EF Falcon GLi

Location: ADELAIDE
SA, Australia

67RCE wrote:
ford-racer46 wrote:
glendogg wrote:
hey guys thanks for helping here but the thing i dont get is how the gli cluster was spot on with the speed and now i put the ghia cluster in its out now and i haven't changed wheels or anything

Maybe it was the GLI that was broke... :shock:

English please?

The GLI cluster...or maybe there not calibrated the same as XR6 ones

 

_________________

Now, I've got a message for all the other drivers out there. If you smell a delicious, crispy smell after the race, it's not your tailpipe. It's just a little of Shake...and Bake!
SHAKE AND BAKE

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:30 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 14

Joined: 4th Feb 2006

Ride: ef falcon

Location: melbourne
VIC, Australia

what im trying to say is changing the cluster shouldnt effect the speedo readings nar the gli cluster was spot on with the speed
Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:42 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 580

Joined: 9th Sep 2009

Ride: EF Falcon GLi

Location: ADELAIDE
SA, Australia

glendogg wrote:
what im trying to say is changing the cluster shouldnt effect the speedo readings nar the gli cluster was spot on with the speed

Oh can only be a faulty cluster then

 

_________________

Now, I've got a message for all the other drivers out there. If you smell a delicious, crispy smell after the race, it's not your tailpipe. It's just a little of Shake...and Bake!
SHAKE AND BAKE

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 24, 2010 11:43 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

glendogg wrote:
what im trying to say is changing the cluster shouldnt effect the speedo readings nar the gli cluster was spot on with the speed

ghia cluster was auto and 323 diff?

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Tue May 25, 2010 1:21 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 4326

Joined: 30th Oct 2006

Gallery: 18 images

Ride: Envi EF

Location: Grafton
NSW, Australia

hans hartman wrote:
ghia cluster was auto and 323 diff?


Doesnt make a difference to the clusters.

With a 3.23 diff + 5 spd (EF) I was on 2k rpm @100kmhr, with 3.45s I sit on a smidge under 2200 rpm @ 100kmhr so I'd be double checking with a gps or against another car what speed you're actually doing.

 

_________________

>>>EF Futura T build<<<

Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Tue May 25, 2010 10:25 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 14

Joined: 4th Feb 2006

Ride: ef falcon

Location: melbourne
VIC, Australia

cheers guys i havnt acally checked with a gps i was just going off other cars on the road and how the 2 clusters read differently ill go for a drive 2moz and try it out with the gps thanks for the help
Top
 Profile  
 
 
 Post subject: Re: speedo is out 10 km
Posted: Mon May 31, 2010 9:38 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 14

Joined: 4th Feb 2006

Ride: ef falcon

Location: melbourne
VIC, Australia

haha i found the problem guys the guy i bought the cluster off put el back grounds instead of ef when he put the needle back on he didnt sit it on zero he sat it bout 10mm below 0 all i got to do is pull it apart again but i appretiate your help guys
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 8:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names