Fordmods Logo

tx5 telstar motor change probs. 


Page 1 of 1 [ 1 post ] 

 Post subject: tx5 telstar motor change probs.
Posted: Tue Sep 12, 2006 8:05 pm 
Getting Side Ways
User avatar

Age: 33

Posts: 850

Joined: 10th Nov 2004

Gallery: 20 images

Ride: 03 BA Fairmont

Location: Forest Lake
QLD, Australia

Hey guys,
got an interesting little project car - late 80's telstar tx5 ghia. owners have given up on it and left it sitting in the back yard for almost a year, but it's in good nick so i scored it.
they replaced the motor with one they got from a wreckers. the car is a manual, but the donor was automatic.
no idea what exactly has been done and what hasnt, but it's all in and bolted up but the clutch does not dissengage the motor and gearbox. tested by placing in gear, depressing clutch and trying to turn both wheels.
any ideas what is wrong?
i'm guessing that the problem is that the donor was auto, (no spigot bearing etc.) but i can't be sure.



2003 BA Fairmont - Stock standard
1994 U13 cough Nissan Cough Bluebird

Favorite Quotes:
"Sportwagon = homo-erotic wank-fest." - downingj

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 1:35 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names