Fordmods Logo

Whats wrong here? please help 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: Whats wrong here? please help
Posted: Thu May 09, 2013 1:26 am 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

Hey guys

I have a 1994 ED Ghia V8 and have recently installed a 3.45LSD from a EF we also installed the 3.45 speedo cog. The problem is the gearbox is changing up to 3rd but the shift points are high (its a auto) we checked it on diagnostic machine and found out the gearbox is working fine so it is shifting into 4th, but when im driving it, it stays in 3rd and the revs are high, doing 70km it sits on 2000-2500rpm.

I havent taken the car any higher than that as the revs sit high up and started thinking that couldnt be good for the engine.

It aslo changes hard from 1st to 2nd but 2nd to 3rd is ok.

If anyone here can shed some light on this and help me out id appriciate it or even ask me more about it.

Thankyou
Brett
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 1:44 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

The ED has specific ECU's for what diff ratio is fitted.....which runs the auto tranny.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 2:26 am 
Smokin em up
Offline

Age: 23

Posts: 201

Joined: 24th Aug 2012

Ride: 1987 telstar/2004 BA XR6 5spd

Location: Newcastle
NSW, Australia

you will probably need to get the trans ecu from said car or invest in a J3..
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 2:27 am 
Smokin em up
Offline

Age: 23

Posts: 201

Joined: 24th Aug 2012

Ride: 1987 telstar/2004 BA XR6 5spd

Location: Newcastle
NSW, Australia

i know in the ef/el's when you put a higher ratio diff in an auto the shift points will be out of wack and will shift early and over rev and a J3 is needed to compensate
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 6:47 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

it shouldnt be out of whack, I fitted 3,45 to my old eb xr8 and used the 345 speedo gear and it was fine..

easy way to tell is re fit the old speedo gear and see what happens, your speedo wont be accurate but the shift points should be as before.

if your shift points go back to normal after you fit original speedo gear, you can do one of 2 things, you can either fit a speedo corrector at the cluster end to correct the speedo signal or hunt down a ed xr8 trans module..
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 3:49 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

I have changed the dash cluster also if that would do anything. The one in there is out of a 6cyl ed fairmont
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Thu May 09, 2013 4:34 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

there's your problem...
in eb/ed the clusters are specific v8 and 6 cyl, so your tacho is now way out with the 6 cyl cluster..
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 1:17 am 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

So if I put the other cluster back in that should help with whats going on?
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 8:08 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

yep, because you will find that its not reving as hard as you think, 2500 rpm on the 6 cyl cluster is really like 1600rpm on the v8..
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 1:27 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

Alright ill put the other one back in and see how it goes. I only changed it because the V8 one has two gauges that didnt work, Didnt know the 6cyl one would be very different
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 1:30 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

it is, but you can dismantle the clusters and swap gauges about, you could fit the 2 gauges that work into the v8 cluster...
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 1:53 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

Maybe i should look into doing that as I now have another dash cluster
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 4:35 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

Well I put the Ghia cluster back in and it revs normally now Thankyou TroyMan . But it is still 10Km out, what can fix that?
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 4:40 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

did you change the speedo gear to the grey 22 tooth one?
Top
 Profile  
 
 
 Post subject: Re: Whats wrong here? please help
Posted: Fri May 10, 2013 8:22 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

Yes troyman that has been changed.

On the way home from my missus work I noticed the other gauges started to work and it was shifting perfectly and the revs were just right. We were saying the computer just needed to sort itself out with the proper dash cluster in there.

So thankyou to everyone who helped especially Troyman had all the right answers cheers :)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:05 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names