Fordmods Logo

XH Panelvan engine cutting out on de-acceleration??? 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: XH Panelvan engine cutting out on de-acceleration???
Posted: Fri Apr 05, 2013 1:03 pm 
Fordmods Newbie
Offline
User avatar

Age: 60

Posts: 12

Joined: 13th Nov 2012

Gallery: 4 images

Ride: Ford HX Panelvan

Location: Sydney
NSW, Australia

G'day Fella's
I'm having problems with my XH van again :x ...when I take my foot of the accelerator pedal when driving along or when I am backing of to slow down or braking when approaching a round about..the engine cuts out or stalls..if it doesnt stall it just about cuts out and gets going again..the engine idles at the normal idle speed when stopped at lights etc...only recent thing I have noticed different with the van is the intank fuel pump seems a little noisier then it has been over the years (even when the tank is full)...do you think it is the crank angle sensor?..I'm not sure if mine has one as the previous owner had a replacement motor put in and I think it may of been fron an EA..I know I have no cruise control because of this??any help greatly appreciated.
Many thanks,
Baz
Top
 Profile  
 
 
 Post subject: Re: XH Panelvan engine cutting out on de-acceleration???
Posted: Mon Apr 08, 2013 11:50 am 
Fordmods Newbie
Offline
User avatar

Age: 60

Posts: 12

Joined: 13th Nov 2012

Gallery: 4 images

Ride: Ford HX Panelvan

Location: Sydney
NSW, Australia

Bump!...any thoughts? :cry:
Top
 Profile  
 
 
 Post subject: Re: XH Panelvan engine cutting out on de-acceleration???
Posted: Tue Apr 09, 2013 11:59 am 
Fordmods Newbie
Offline
User avatar

Age: 60

Posts: 12

Joined: 13th Nov 2012

Gallery: 4 images

Ride: Ford HX Panelvan

Location: Sydney
NSW, Australia

I did a few things yesterday that has made a very slight improvement..but it still on occasions wants to stall on breaking...I know I should of done these changes one by one and then taken the car for a drive after each thing I did....but I'm getting old and impatient so I just got stuck into changing a few things...they were..

air filter

disconnected the idle control solinoid plug and cranked the motor..it didnt start which I'm led to believe its working then as I reconnected and it started and idled perfect.

twisted the black knob back and forth on the idle control solinoid.

changed the black thing on the fire wall that has a vacuum tube and wire plug in??

jiggled the ecu a bit


I reckon it's a vacumm prob or fuel pump.

go figure...I'm still scratching my head.
Top
 Profile  
 
 
 Post subject: Re: XH Panelvan engine cutting out on de-acceleration???
Posted: Wed Apr 10, 2013 3:03 pm 
Parts Gopher
Offline
User avatar

Age: 53

Posts: 74

Joined: 17th Sep 2012

Gallery: 24 images

Ride: XH Ute

Location: Townsville
QLD, Australia

I had a problem a while back that sound similar. I took the Idle control valve off and cleaned it well with carb cleaner. It's not stalled since.
Top
 Profile  
 
 
 Post subject: Re: XH Panelvan engine cutting out on de-acceleration???
Posted: Wed Apr 10, 2013 9:54 pm 
Fordmods Newbie
Offline
User avatar

Age: 60

Posts: 12

Joined: 13th Nov 2012

Gallery: 4 images

Ride: Ford HX Panelvan

Location: Sydney
NSW, Australia

falcopops wrote:
I had a problem a while back that sound similar. I took the Idle control valve off and cleaned it well with carb cleaner. It's not stalled since.



Thanks for you reply mate..I'll give it a go.
Cheers
Top
 Profile  
 
 
 Post subject: Re: XH Panelvan engine cutting out on de-acceleration???
Posted: Wed Apr 24, 2013 10:07 pm 
Fordmods Newbie
Offline
User avatar

Age: 60

Posts: 12

Joined: 13th Nov 2012

Gallery: 4 images

Ride: Ford HX Panelvan

Location: Sydney
NSW, Australia

Well I seem to have solved the problem..I changed the IDLE SPEED/ AIR CONTROL and it seems to be going fine..EXCEPT.....Going like a champion now.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Oct 21, 2017 3:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names