Fordmods Logo

ford el indicator wont flash 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: ford el indicator wont flash
Posted: Thu Jun 26, 2014 4:53 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 6

Joined: 29th Dec 2013

Ride: ford el 98

Location: melbourne
VIC, Australia

Anyone able to please help with this. When i turn on hazards or us indicator, the lights turn on solid and dont flash. Up until today it would only happen occassionally though now it happens all the time. Any help appreciated.
Top
 Profile  
 
 
 Post subject: Re: ford el indicator wont flash
Posted: Thu Jun 26, 2014 6:14 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

have you tried another flasher relay

does it do it with all the lights
Top
 Profile  
 
 
 Post subject: Re: ford el indicator wont flash
Posted: Thu Jun 26, 2014 6:17 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 6

Joined: 29th Dec 2013

Ride: ford el 98

Location: melbourne
VIC, Australia

Will try a different relay in the morning. Is it the top left one at the fuse box? And yes.. It does it with all indicator lights and on the cluster.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:44 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names