Fordmods Logo

Radio and clock won't work-AU 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 10:13 pm 
Fordmods Newbie
Offline

Age: 21

Posts: 4

Joined: 7th Jul 2014

Ride: Au falcon

Location: Sydney
NSW, Australia

Ok, so, my cars radio and dash clock have stopped working, I have checked all the fuses and
Found that the "radio no2" fuse has blown, it's an aftermarket radio that was professionally fitted a long time ago, I was just wondering where I would start on fixing this problem as it just keeps blowing the fuse, i know it's a dead short, but I can't figure out where
Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 10:31 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2098

Joined: 19th Jan 2005

Gallery: 9 images

Ride: 5L 5 speed Fairmont Ghia

Location: St Maoris
NSW, Australia

Autickfordman99 wrote:
Ok, so, my cars radio and dash clock have stopped working, I have checked all the fuses and
Found that the "radio no2" fuse has blown, it's an aftermarket radio that was professionally fitted a long time ago, I was just wondering where I would start on fixing this problem as it just keeps blowing the fuse, i know it's a dead short, but I can't figure out where


Define "professionally fitted". Back before I knew what I was doing, I had stereos "professionally fitted" by Strathfield and JB. I was disgusted when down the track I find out that the wiring was butchered for a twist and tape fitment.
Hell, even the iPod adapter accessory fitted to my car (fitted by the dealer before delivery) only used crappy scotch locks on the power/earth wires. I was expecting a better job on a brand new car.

I would start at the back of the head unit. Look for exposed wiring. If there is none found, unplug radio from wiring harness, replace fuse. If the fuse pops when the radio is missing, keep looking at the wiring.

 

_________________

Remember kids, the more pages of crap in your build thread, the bigger your e-penis is

Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 10:36 pm 
Fordmods Newbie
Offline

Age: 21

Posts: 4

Joined: 7th Jul 2014

Ride: Au falcon

Location: Sydney
NSW, Australia

I have followed all visible wiring, nothing exposed or rubbing on sharp edges
All connections are soldered and covered in heat shrink, I really have no clue what else to do
Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 10:41 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2698

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Autickfordman99 wrote:
I have followed all visible wiring, nothing exposed or rubbing on sharp edges
All connections are soldered and covered in heat shrink, I really have no clue what else to do



did you refit the fuse??
Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 10:46 pm 
Fordmods Newbie
Offline

Age: 21

Posts: 4

Joined: 7th Jul 2014

Ride: Au falcon

Location: Sydney
NSW, Australia

Yes, 3, after each time I unplugged the radio, then the clock and it's still doing it, I know it's in the wiring before these components.
Is there something that the current passes through before the radio?
Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Mon Jul 07, 2014 11:11 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2098

Joined: 19th Jan 2005

Gallery: 9 images

Ride: 5L 5 speed Fairmont Ghia

Location: St Maoris
NSW, Australia

There's not a lot between the clock and the fuse box. The common fuse for the clock and the radio is the 5A fuse, fuse 3.

This fuse is responsible (in part) for:
*Ignition switch radio supply
*Rear demister relay
*power mirrors

...a few more things to look at.

 

_________________

Remember kids, the more pages of crap in your build thread, the bigger your e-penis is

Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Tue Jul 08, 2014 12:07 am 
Fordmods Junkie
Offline
User avatar

Posts: 2698

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
 
 Post subject: Re: Radio and clock won't work-AU
Posted: Tue Jul 08, 2014 6:05 pm 
Fordmods Newbie
Offline

Age: 21

Posts: 4

Joined: 7th Jul 2014

Ride: Au falcon

Location: Sydney
NSW, Australia

Okay, so what is everything that's wired up to that circuit, or how do I find out
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Oct 17, 2017 4:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names