Fordmods Logo

wired up relay wrong (I think):'( on BA now no power?? HELP 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: wired up relay wrong (I think):'( on BA now no power?? HELP
Posted: Sat Aug 29, 2015 10:24 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 2

Joined: 29th Aug 2015

Ride: ba falcon

Location: halekulani
NSW, Australia

Hi everyone I'm new to this group. I tries to write up spotties to a BA falcon even though I followed the wiring harness instructions I must of done something wrong as I went to hook up the positive terminal the relay buzzed and the battery kinda threw a spark . I decided to finish in daylight. And went to lock the car it wouldn't acknowledge the key pad I put key in ignition it gave me no reds except a red (!).. The lights won't work Infact nothing works!!
I'm assuming (hoping) it's a fuse but have no idea... I've googled and googled but to no avail ... Kinda starting to freak out..
Please help..
Also I have wired spotties before to a toyota but had no dramas..
Top
 Profile  
 
 
 Post subject: Re: wired up relay wrong (I think):'( on BA now no power?? HELP
Posted: Sat Aug 29, 2015 11:12 pm 
Fordmods Junkie
Online
User avatar

Posts: 2703

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

you have possibly wired up the power/earth wiring a*** about or something
Top
 Profile  
 
 
 Post subject: Re: wired up relay wrong (I think):'( on BA now no power?? HELP
Posted: Sun Aug 30, 2015 12:48 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 2

Joined: 29th Aug 2015

Ride: ba falcon

Location: halekulani
NSW, Australia

Hi and thankyou. Turns out I had the switched wired up wrong.. ( & the battery wasn't connected silly me)

Now I the spotties work but the car wont start.. It locks/unlocks & the reds on the dash come.on but it won't wind over. It's like trying to start an auto in drive *if that makes sense *
The radio is displaying COde but I didn't think that would effect the running of the car..
I'm thinking again this is a fuse * but I have no idea which one*.. Am soo frustrated right now..
Top
 Profile  
 
 
 Post subject: Re: wired up relay wrong (I think):'( on BA now no power?? HELP
Posted: Sun Aug 30, 2015 1:22 pm 
Fordmods Junkie
Online
User avatar

Posts: 2703

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

willowsdiy wrote:
Hi and thankyou. Turns out I had the switched wired up wrong.. ( & the battery wasn't connected silly me)

Now I the spotties work but the car wont start.. It locks/unlocks & the reds on the dash come.on but it won't wind over. It's like trying to start an auto in drive *if that makes sense *
The radio is displaying COde but I didn't think that would effect the running of the car..
I'm thinking again this is a fuse * but I have no idea which one*.. Am soo frustrated right now..



i'm tending to agree ... but .. i don't know enuf re Ba/BF to offer any real help here :oops:

all i can say is check fuses/relays in engine bay & dash.
Top
 Profile  
 
 
 Post subject: Re: wired up relay wrong (I think):'( on BA now no power?? HELP
Posted: Sun Aug 30, 2015 9:31 pm 
Technical Contributor
Offline
User avatar

Age: 27

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Check all the fuses... You get a test light and probe the terminals in the top of fuse (either side of the rating 10A 20A 30A etc)... If you get a glow from both sides of the fuse it isn't blown... If you get a glow from one side and not the other then thats the blown one...

You can check all the fuses in under a minute with this system...

Based on your ICC saying code, I'd be suspecting the power to the BEM...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Oct 21, 2017 1:54 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names