Fordmods Logo

AU Fairlane Dash Cluster Issues after Conversion 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: AU Fairlane Dash Cluster Issues after Conversion
Posted: Thu Nov 02, 2017 7:32 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 1st Nov 2017

Ride: 89 Ford Courier - 5.0L AU Engine

Location: Whangarei
New Zealand

Hi, I've got an old 89 courier that we have done the 5L V8 conversion from a 1999 Fairlane.
I need some help to finish off the electrical parts so the dash works correctly. Any help with the following issues will help a lot. A little background on what was done, Complete wiring harness overlayed original courier harness minus body harnesses for doors and audio, has AU ECU, BEM, engine, auto trans, dash and ignition. Still using courier loom for lights, horn, radio and fan/heater. Air bags, ABS and A/C not used in any of it. Have got the indicator dash lights transferred from old dash cluster plug to the new loom ok but have a problem with:

1. The ECON is stuck on and won't come off
2. There is a little flashing arrow pointing at the rear of the car diagram. Don't even know what it is..
3. The high beam warning light is on but turns off when the high beam is turned on
4. The dash light seem to be negatively switched??
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Nov 21, 2017 6:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names