Fordmods Logo

2009 fg xr6 fuse problem 


Page 1 of 1 [ 1 post ] 

 Post subject: 2009 fg xr6 fuse problem
Posted: Sun Apr 10, 2016 2:00 am 
Fordmods Newbie

Age: 28

Posts: 1

Joined: 10th Apr 2016

Ride: Ford fg xr6

Location: Kelso
QLD, Australia

Hey guys long story short i went to check all my fuses under dash and the ones in engine bay to see if one was blown because im getting no power to my aircon blower (under glovebox)
So i pulled out all the fuses one by 1 and put them back in but im unsure if i have broken one in the process or ruined one ect i cannot start my car now i turn the accessories on everything is all fine try to crank it over and it makes the lil click noise it makes before it cranks over but just wont crank over now. any ideas on what fuse i should be looking at to rectify this issue or is there anything else i could of shorted out checking the fuses not 100% sure if the car was fully turned off when checking the fuses was going back and forth turning it on and off trying to find initial problem.
Regards nev.
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 3:39 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names