Fordmods Logo

2013 Ford Territory 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: 2013 Ford Territory
Posted: Tue Dec 20, 2016 2:17 pm 
Fordmods Newbie
Offline

Age: 47

Posts: 2

Joined: 20th Dec 2016

Ride: Ford Territory 2013

Location: Daw Park
SA, Australia

I reversed out of the carport and when I put the car in drive the engine check light came on, followed by the DSC icon (car swerving light) and an orange exclamation mark. The car had limited accelerator. I called the RAA and not much was showing up immediately, but eventually a high fuel reading and 2 x communicator reading (suggested they were not communicating). My car was towed to the nearest Ford Dealership but at this stage they have found nothing. Any suggestion would be appreciated, as we bought the car at the start of the year, it has been great. We have regularly serviced, no towing, 1 set of new tyres 10 weeks ago. HELP!
Top
 Profile  
 
 
 Post subject: Re: 2013 Ford Territory
Posted: Tue Dec 20, 2016 6:06 pm 
Smokin em up
Offline
User avatar

Age: 34

Posts: 280

Joined: 24th Jun 2014

Gallery: 4 images

Ride: BA XR6 Turbo

Location: Jamestown
SA, Australia

Diane wrote:
I reversed out of the carport and when I put the car in drive the engine check light came on, followed by the DSC icon (car swerving light) and an orange exclamation mark. The car had limited accelerator. I called the RAA and not much was showing up immediately, but eventually a high fuel reading and 2 x communicator reading (suggested they were not communicating). My car was towed to the nearest Ford Dealership but at this stage they have found nothing. Any suggestion would be appreciated, as we bought the car at the start of the year, it has been great. We have regularly serviced, no towing, 1 set of new tyres 10 weeks ago. HELP!


Check engine light indicates a fault, and will put the car into LHM (limp home mode). not sure what you mean by high fuel reading.
to me communication problems aren't a major issue unless there constantly re occurring after resetting, can be caused by the module not ready.
Exclamation light is brake fail and the DSC light is for the ABS/DSC unit.
I'm going to go with Faulty battery or alternator not charging. because all these things came up at once. I have read in the past that a faulty battery can cause all these.
Was there any codes saying battery voltage low at all? Either way I'd try a new battery first and see what happens from there.

 

_________________

Current Ride
BA XR6 Turbo, P3 Paint, BP Trim, Fully Stock Mods to Come!
1996 EF Falcon furura, White.
BA XR6 , P3 Paint, BG Trim, crashed in front but thinking of fixing!

BLUE BLOOD
Previous Rides
1997 EL Falcon
1980 Ford Escort

Top
 Profile  
 
 
 Post subject: Re: 2013 Ford Territory
Posted: Tue Dec 20, 2016 11:32 pm 
Fordmods Newbie
Offline

Age: 47

Posts: 2

Joined: 20th Dec 2016

Ride: Ford Territory 2013

Location: Daw Park
SA, Australia

Thanks Robert. After research today I requested a thorough check of the wheel sensors. The mechanics are thinking it is a fuel sensor but are nervous about ordering the part because it is worth $1500.00. I will give them a ring & ask if they have tried using a new battery. I don't want to meddle but no one appears to be certain about what the problem is & I am hoping similar experiences will provide some answers....hopefully quickly!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon May 01, 2017 7:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names