Fordmods Logo

96 EF, Futura, low beam, passenger headlight dim 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: 96 EF, Futura, low beam, passenger headlight dim
Posted: Tue Sep 22, 2020 11:51 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 2

Joined: 22nd Sep 2020

Ride: 1996 EF Futura

Location: Melbourne
VIC, Australia

Hi!

Not a car guy, but not too bad with my hands. (built computers 30 years, soldered new power button into coffee machine, fixed washing machine etc)
Sadly, I can't seem to find youtube videos on the late 90s cars, more stuff in the early 00's. (B series?)

Passenger headlight is on but dim as can be, I tapped it a couple of weeks ago and it came good but she's misbehaving ongoing now.


I have a couple of hopefully easy questions! Sorry.


Am I right in thinking there's actually 2 globes per headlight, 1 highbeam, 1 low beam?
Can anyone find a decent video, of pulling the globe out?
I hear some stuff about cabling, fuses and other potential common issues with this model, would the best, smartest test - be to swap the headlights across, if the problem 'follows' me to the other side, then it's clearly the globe, order one, pop it in?


Thanks guys - y'all good!
Top
 Profile  
 
 
 Post subject: Re: 96 EF, Futura, low beam, passenger headlight dim
Posted: Sun Sep 27, 2020 10:33 am 
Fordmods Junkie
Online
User avatar

Posts: 3503

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

dimfella wrote:
Hi!

I have a couple of hopefully easy questions! Sorry.


Am I right in thinking there's actually 2 globes per headlight, 1 highbeam, 1 low beam?
Can anyone find a decent video, of pulling the globe out?
I hear some stuff about cabling, fuses and other potential common issues with this model, would the best, smartest test - be to swap the headlights across, if the problem 'follows' me to the other side, then it's clearly the globe, order one, pop it in?


Thanks guys - y'all good!



presume it's for the ef? which from memory has 2 globes 1 hi/low [on outer] & 1 hi [inner]. if your tapping it & it's coming good it's either the wiring socket on back of globe or the globe itself with the problem. if you have a spare globe [for the problem globe] swap that in & try it. just remember to keep the glass section of the globe clean of finger prints.
Top
 Profile  
 
 
 Post subject: Re: 96 EF, Futura, low beam, passenger headlight dim
Posted: Sun Sep 27, 2020 12:32 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 2

Joined: 22nd Sep 2020

Ride: 1996 EF Futura

Location: Melbourne
VIC, Australia

Mad2 wrote:
dimfella wrote:
Hi!

I have a couple of hopefully easy questions! Sorry.


Am I right in thinking there's actually 2 globes per headlight, 1 highbeam, 1 low beam?
Can anyone find a decent video, of pulling the globe out?
I hear some stuff about cabling, fuses and other potential common issues with this model, would the best, smartest test - be to swap the headlights across, if the problem 'follows' me to the other side, then it's clearly the globe, order one, pop it in?


Thanks guys - y'all good!



presume it's for the ef? which from memory has 2 globes 1 hi/low [on outer] & 1 hi [inner]. if your tapping it & it's coming good it's either the wiring socket on back of globe or the globe itself with the problem. if you have a spare globe [for the problem globe] swap that in & try it. just remember to keep the glass section of the globe clean of finger prints.



Thanks for that, I did check a day after this, yeah it's a 2 globe system - I think the inner globe = highbeam and outer appears to be the low beam.
Tapping did work - has stopped fixing it now though. Could you recommend a decent replacement globe?

I do know about the fingerprints! One of the few car things I know - thanks heaps.
Top
 Profile  
 
 
 Post subject: Re: 96 EF, Futura, low beam, passenger headlight dim
Posted: Sun Sep 27, 2020 9:45 pm 
Fordmods Junkie
Online
User avatar

Posts: 3503

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

dimfella wrote:

Thanks for that, I did check a day after this, yeah it's a 2 globe system - I think the inner globe = highbeam and outer appears to be the low beam.
Tapping did work - has stopped fixing it now though. Could you recommend a decent replacement globe?

I do know about the fingerprints! One of the few car things I know - thanks heaps.



first check & make sure it's not a problem with the plug socket. any standard globe would do [unless you have something specific in mind] which i think is 55/60 ?. if you go too high a wattage globe you will melt the headlight.

unless you have an XR front/lights you should have high/low outers with high inners.


edit - just checked out the manuals here & they only list a low on outer & a high on the inner ? but yet i would swear that all i have wrecked [not many] here have had a high/low combo on the outers??

if yours is the low only i can't help with what is used as i don't offhand know :oops:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Oct 21, 2020 1:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names