Fordmods Logo

AU Falcon failing Alernator or bad connection? 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: AU Falcon failing Alernator or bad connection?
Posted: Mon Sep 02, 2019 1:23 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1425

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

i've noticed that when i go and start my car in the morning, it will start & idle just fine - the battery is nicely charged & it doesnt struggle to start. but when i go to do the morning ritual of cleaning the windscreen with the washers & wipers they are very sluggish untill either a minute or so after startup or when i simply blip the throttle & not by much either, usually 50 - 100 rpm off idle will be enough to get everything working perfectly again & then after that it wont have any dramas untill the next morning. i'm hoping its a simple thing but if it is a bad Alt how long does it have to live?

few things too add; the battery is about 2 years old, and the car itself hasnt had a service in a long time (financial constraints suck!)

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
 Post subject: Re: AU Falcon failing Alernator or bad connection?
Posted: Wed Sep 11, 2019 10:50 pm 
Technical Contributor
Offline

Posts: 533

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

Does charge warning light work when you switch on reds

Globe ??
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Oct 21, 2019 3:52 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names