Fordmods Logo

BA Door Actuator Not Locking / Unlocking But Otherwise Works 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: BA Door Actuator Not Locking / Unlocking But Otherwise Works
Posted: Tue Mar 21, 2017 12:44 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 28th Nov 2016

Ride: 2004 BA Falcon XT

Location: Melbourne
VIC, Australia

Hi

Wondering if anyone can point me in the right direction for this, the RHR door actuator doesn't lock, but the rest of its functions seem to work; unlocks the other doors when you open it, lights come on..

Buttt it won't lock, no noises, nothing. It first happened after I washed the car (or I noticed it at least) a while ago, then started working again, but now it's been dead for quite a while.. All other doors lock except this one.

Is there any hidden fuses or relays to check ? Or would this be a faulty BEM ?

It is a BA 2004, but it's been garaged all its life and is basically like new, so I was thinking it was somewhat unlikely for a rust hole and water logged cables or something similar... ? :?
Top
 Profile  
 
 
 Post subject: Re: BA Door Actuator Not Locking / Unlocking But Otherwise Works
Posted: Thu Mar 23, 2017 5:50 pm 
Technical Contributor
Offline

Posts: 490

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

check wiring at B pillar plug for water and or corrosion -
replace actuator
Top
 Profile  
 
 
 Post subject: Re: BA Door Actuator Not Locking / Unlocking But Otherwise Works
Posted: Thu Mar 23, 2017 6:15 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 28th Nov 2016

Ride: 2004 BA Falcon XT

Location: Melbourne
VIC, Australia

I forgot to mention I did already change the actuator, and it still didn't work after this. Now today I go to double check the wiring in the B pillar (which is bone dry, looks brand new) the door lock is working again... :x
Anything else that could be the culprit ?
Top
 Profile  
 
 
 Post subject: Re: BA Door Actuator Not Locking / Unlocking But Otherwise Works
Posted: Sun Mar 26, 2017 8:05 am 
Technical Contributor
Offline

Posts: 490

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

If left doors are working then not BEM module as they are on the same circuit - then you have a fault in wiring or faulty actuator
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Oct 23, 2017 9:55 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names