Fordmods Logo

BA electrical issue 


Page 1 of 1 [ 2 posts ] 

 Post subject: BA electrical issue
Posted: Sat Jun 07, 2014 7:09 pm 
Fordmods Newbie

Age: 55

Posts: 1

Joined: 4th May 2014

Ride: 2001 Au falkon

Location: Melbourne
VIC, Australia

Hi all, desperate need of help, I have a 2010 BA XR6 on gas, the battery failed on me, I bought a new one and fitted but now I have a problem, the dials stay lit all the time, even with key removed....the airbag lite is lit, when I turn the ignition on, no dials work, or anything comes on other than the airbag lite, the back lite on the dials flash on a set time, about every 15 seconds...anyone any ideas? Ps racv tried computer for errors but couldnt get a link...
 Post subject: Re: BA electrical issue
Posted: Sun Jun 08, 2014 9:31 pm 
Getting Side Ways

Posts: 434

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

check that battery is connected correct and not backwards (Should be negative to earth) - check all earths have been connected at battery - check all cables are connected to positive side at battery -

check fuses and fuse links in underhood fuse box -
check fuses in under dash fusebox - especially fuses 2-3-24-25-27-28-29
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 6:11 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names