Fordmods Logo

Battery conected the wrong way 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Battery conected the wrong way
Posted: Thu Nov 21, 2013 5:25 am 
Parts Gopher
Offline
User avatar

Age: 28

Posts: 80

Joined: 21st Jan 2009

Gallery: 2 images

Ride: 1995 Ford XG Ute

Location: melbourne
VIC, Australia

Hi some bright spark connected the battery the wrong way in my xg because he was busy talking and not paying attention,
now whats the list of things it will have blown?

car cranks but wont start, fuel pump primes with ignition on

Cheers

 

_________________

95' XG
93' EB
custom buggy with 900cc yamaha engine

Top
 Profile  
 
 
 Post subject: Re: Battery conected the wrong way
Posted: Thu Nov 21, 2013 5:37 am 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

Check all fusible links under the bonnet. They will all be in a row most likely on the drivers side. Easy enough to spot the f**k one

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: Battery conected the wrong way
Posted: Thu Nov 21, 2013 9:47 am 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Alternator will be f**k.
Possibly stereo and ECU as well.

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
 
 Post subject: Re: Battery conected the wrong way
Posted: Sat Nov 23, 2013 8:15 pm 
Parts Gopher
Offline
User avatar

Age: 28

Posts: 80

Joined: 21st Jan 2009

Gallery: 2 images

Ride: 1995 Ford XG Ute

Location: melbourne
VIC, Australia

iv been told that as long as the ignition is off it wont fry the ecu? any truth in that? fusible links all fine swapped out of another car just to be sure
no fuses blown in the dash

the battery wasn't done up just touched the terminal to the battery and had a bigger spark then normal that's what stopped him doing it up, so hopefully just done a fuse somewhere and just touching it the wrong way hasn't fried anything major

 

_________________

95' XG
93' EB
custom buggy with 900cc yamaha engine

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names