Fordmods Logo

car just stops 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: car just stops
Posted: Sat Jun 02, 2012 6:23 pm 
Parts Gopher
Offline

Posts: 72

Joined: 30th May 2010

Gallery: 9 images

Ride: el fairmont

Location: canberra act
QLD, Australia

el fairmont ghia
hi all this problem has been going on for too long ,originaly i bought the car on the gold coast qld drove it home to redcliffe on Brisbane nth side ,it felt a little slugish the next day i set the timing correctly & it was a new beast took it far a spin around the streets then after about 20min it stalled & wouldn't start again ,about half an hour later went back & it started ,got it home ,then it died again . I replaced the dizzy,the cap button ,leads,plugs coil, all good took it for a spin again got back yay fixed ,left it sitting idling then it stalled again .
Got it going again put it in the shop ,they changed idle control valve and tps and said they had it running for ages ,as i was picking it up at the workshop it stalled ,they replaced the ecu with a second hand one from wreckers ,all good again .
It was ok for a month but didn't idle nice now the other day a couple of times whilst driving i had no response from the accelerator then fine again then the next day i pulled up at home (music loud) as i went to turn it off i noticed it wasn't running but no warning light or gauges were working but it would crank . Now im thinking the ignition switch ,has anyone else had this fault from a faulty ignition switch :cry:
Top
 Profile  
 
 
 Post subject: Re: car just stops
Posted: Sat Jun 02, 2012 6:26 pm 
Getting Side Ways
Offline
User avatar

Age: 24

Posts: 1006

Joined: 1st Oct 2010

Gallery: 14 images

Ride: EF XR8

Location: Richmond,
NSW, Australia

Could be a fuel pump issue?
Or some sort of fuel delivery problem.

 

_________________

Blue blooded.

Top
 Profile  
 
 
 Post subject: Re: car just stops
Posted: Sat Jun 02, 2012 6:35 pm 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Did you replace the TFI module at the same time as you did the dizzy?
Did you use heatsink paste when you fitted it?

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
 
 Post subject: Re: car just stops
Posted: Sun Jun 03, 2012 2:51 pm 
Parts Gopher
Offline

Posts: 72

Joined: 30th May 2010

Gallery: 9 images

Ride: el fairmont

Location: canberra act
QLD, Australia

Fuel pump pressure was checked when it to the workshop ,the dizzy was a complete one from a working ed falcon ,the part that makes me think it is ignition switch is when it won't go the digital part & the instruments don't work on the dash
Top
 Profile  
 
 
 Post subject: Re: car just stops
Posted: Wed Jun 13, 2012 2:38 am 
Parts Gopher
Offline

Posts: 72

Joined: 30th May 2010

Gallery: 9 images

Ride: el fairmont

Location: canberra act
QLD, Australia

Fixed it on the weekend it was 2 faults ,the ignition switch was faulty & the TFI was also faulty replaced ignition switch with second hand one & replaced ignition module with a brand new one and hasn't stopped in 3 days :lol: :D :P
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:53 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names