Fordmods Logo

Dash Dead car will not start Ef2 falcon 95 i need help 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Dash Dead car will not start Ef2 falcon 95 i need help
Posted: Wed Jan 01, 2014 1:19 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 29th Mar 2011

Ride: 95 XR8 Man EF2 Falcon

Location: hamilton
New Zealand

So short story is the car stopped one day under normal conditions. the whole dash wend dead, i have since found out that the center row in the fuse box has lost power (if i supply it power the car will run fine with no problems). now im thinking it may be a relay that has s**t itself, any one have an idea where this relay that supplies this bank is? dont realy want to pull the whole dash to pieces hoping to stumble across it. or any other ideas on the problem? Thanks.
Top
 Profile  
 
 
 Post subject: Re: Dash Dead car will not start Ef2 falcon 95 i need help
Posted: Wed Jan 01, 2014 1:36 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

Check all the fuses in the main fuse box next to the battery. Particularly check the 100A MAIN fuse and the IGN fuse. I've attached a pic of what it looks like. Keep in mind that 100A fuse is bolted in with 2x 10mm bolts and isn't just pushed in like the rest of them. Also make sure all your earths are good and make sure all the wiring to the battery and alternator is all good.

Gab

 

 

Attachments:
File comment: check the fuses in here first.
P1020868 (Medium).JPG
P1020868 (Medium).JPG [ 54.9 KiB | Viewed 73 times ]
Top
 Profile  
 
 
 Post subject: Re: Dash Dead car will not start Ef2 falcon 95 i need help
Posted: Wed Jan 01, 2014 2:21 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 29th Mar 2011

Ride: 95 XR8 Man EF2 Falcon

Location: hamilton
New Zealand

Gab1 wrote:
Check all the fuses in the main fuse box next to the battery. Particularly check the 100A MAIN fuse and the IGN fuse. I've attached a pic of what it looks like. Keep in mind that 100A fuse is bolted in with 2x 10mm bolts and isn't just pushed in like the rest of them. Also make sure all your earths are good and make sure all the wiring to the battery and alternator is all good.

Gab



thanks, not the problem, all fuses are fine. Main earth is tight as and all terms on the alt are also tight. the car runs fine when i supply the middle bank of fused in side the car with 12v, do you know of any relay between there and the battery there must be something blocking the power. i will have a closer look at the ignition and see if thats faulty on the 'on' position.
Top
 Profile  
 
 
 Post subject: Re: Dash Dead car will not start Ef2 falcon 95 i need help
Posted: Wed Feb 19, 2014 9:47 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1966

Joined: 13th Aug 2005

Ride: 2000 Au wagon

Location: some where in nsw
NSW, Australia

did you ever solve this , it could be a fusible link

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names