Fordmods Logo

dash fault, no door ajar/speedo/odo display 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: dash fault, no door ajar/speedo/odo display
Posted: Wed Jan 13, 2016 8:33 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 12

Joined: 3rd Oct 2013

Ride: xh ute, v8 nc lane

Location: geraldton
WA, Australia

Help.....
Anyone know what would cause the main displays to fail on a nc fairlane dash?
All the back lights are working but I often loose the odo/Speedo and the door ajar warning display .
Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Wed Jan 13, 2016 8:38 pm 
Getting Side Ways
Offline
User avatar

Posts: 2573

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Wed Jan 13, 2016 10:17 pm 
Technical Contributor
Offline
User avatar

Age: 27

Posts: 3703

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

bad globes? bad globe connection?

Is it there but just doesn't illuminate?

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Wed Jan 13, 2016 10:28 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 12

Joined: 3rd Oct 2013

Ride: xh ute, v8 nc lane

Location: geraldton
WA, Australia

Na, not a globe issue as the backlights are working , but only the digital displays are failing , in my workshop manual it says there is a " instrument microcomputer" ( printed on page 231, gregory's manual No. 262. If any one cares for my reference)... Could this be the cause?

 

 

Attachments:
IMAG0215_1.jpg
IMAG0215_1.jpg [ 138.71 KiB | Viewed 21 times ]
Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Wed Jan 13, 2016 10:52 pm 
Technical Contributor
Offline
User avatar

Age: 27

Posts: 3703

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

anything is possible I guess... Unless there is a bad connection inside the cluster... Most LCD's are attached to the circuit board with some form of ribbon cable... Maybe try pulling it apart and see if there is any damage?

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Sat Jan 16, 2016 4:54 am 
Fordmods Newbie
Offline

Age: 37

Posts: 12

Joined: 3rd Oct 2013

Ride: xh ute, v8 nc lane

Location: geraldton
WA, Australia

Thanks TimmyA, will check it out when I've got time.
Top
 Profile  
 
 
 Post subject: Re: dash fault, no door ajar/speedo/odo display
Posted: Fri Jan 22, 2016 1:13 am 
Fordmods Newbie
Offline

Age: 37

Posts: 12

Joined: 3rd Oct 2013

Ride: xh ute, v8 nc lane

Location: geraldton
WA, Australia

All sorted thanks everyone. Turned out to be a dodgy connection on the instrument fuse.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu May 25, 2017 6:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names