Fordmods Logo

demister icon on dash not working, even after globe change. 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: demister icon on dash not working, even after globe change.
Posted: Sat Sep 15, 2012 1:16 am 
Oompa Loompa
Offline

Posts: 42

Joined: 24th Nov 2008

Location: Melbourne
VIC, Australia

Hey guys,

im selling my 94 EF and needed to change the globe for the speedometer (for the roadworthy), while I had the cluster out I changed nearly all the globes except for the indicators and "main" backlighting globes. My Demister icon in the dash still wont light up, even though the demister works fine, the icon hasnt worked for ages and I thought it was just the globe, guess not, any suggestions?

The globes I changed were small blue and black ones, a majority were blue.

Thanks,

p.s. even got the clock going again! ha
Top
 Profile  
 
 
 Post subject: Re: demister icon on dash not working, even after globe change.
Posted: Sat Sep 15, 2012 1:17 am 
Oompa Loompa
Offline

Posts: 42

Joined: 24th Nov 2008

Location: Melbourne
VIC, Australia

forgot to ask, I gotta change my steering wheel too. Due to the airbag is this a pain in the a** to do?

thanks again,
Top
 Profile  
 
 
 Post subject: Re: demister icon on dash not working, even after globe change.
Posted: Sat Sep 15, 2012 2:50 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

How to change the steering wheel on an EF/EL Falcon Tech Doc
I advise getting yourself a steering wheel puller, makes life 100,000x easier and saves on expensive dental treatment when the wheel knocks your front teeth out! If you can't get hold of one do as the doco says, leave the T50 screw partly on and heave away..
As for the globe, I have the same issue with the Econ globe in my current cluster, it has never worked. My guess is there is a break in the printed circuit on the cluster circuit board as even swapping it for a known working globe makes no difference. Nothing you can do about it but live with it.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: demister icon on dash not working, even after globe change.
Posted: Sat Sep 15, 2012 5:29 pm 
Oompa Loompa
Offline

Posts: 42

Joined: 24th Nov 2008

Location: Melbourne
VIC, Australia

cool, thanks for that doc, printed it out and will give it a go on monday!

While we are on the subject of electrics, I just lost my front drivers side indicator on the freeway!

This indicator has always been a little funny, sometimes when getting in my car I used to notice that it would be sitting a little out or off centre and loose from the guard moulding so I just used to push it in a little. From what I can tell, it seems these indicators are only held in by clips, is that right?

I'll have to get one from the wreckers on monday, hopefully they got a clear one. Another f^%kn thing to do! ahhhhhhhhhhh!!

thanks,
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: arianahose@gmail.com and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 1:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names