Fordmods Logo

Ed 5ltr not starting 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: Ed 5ltr not starting
Posted: Fri Sep 22, 2017 11:06 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 13

Joined: 30th Mar 2014

Ride: Ed xr8

Location: Geelong
VIC, Australia

Howdy I'm trying to get some help identifying why my car won't run I have a ed I swapped to v8 a few years back

I was out driving pulled up to the lights and when I went to go it was sluggish went about 5 metres spluttered back fired surged the whole lot got it a bit further up the road and it died and wouldn't fire up again I got a mate to tow me home

I had a play with it It would turn over n fire but not run then if I tapped the starter with a bit of bar it would fire up and run I did this a few times to move it round the yard some times when I started It would run like it was only on 5 cylinders or what not. Or I'd start it an it would run fine rev good with no signs of a problem and other times it would fire up idle good rev good but then just stall I gave up on it for a while but lately I felt sorry for the old girl and wanna get it going again

But now it won't start up even if I tap the starter it just turns fires like its gonna go but doesn't I don't know what to make of it if anyone has any info help or guesses on what might be wrong I'm all ears thanks
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Oct 23, 2017 4:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names