Fordmods Logo

ED Falcon wont start 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: ED Falcon wont start
Posted: Sat Feb 14, 2015 9:17 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 5

Joined: 30th Jan 2015

Ride: EB Falcon

Location: Auckland
New Zealand

Hey guys looking to fix a problem i have with my ED went for a drive parked it up came back the next day and she wont fire its getting fuel and when i turn the car on i can hear the fuel pump prime the rail but no spark at the leads so i pulled the coil lead off and didn't get a spark there either have checked all fuses and relays and they seem to be working fine replaced the dizzy and coil just to be safe but still no luck

any idea?

thanks guys
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sat Feb 14, 2015 9:28 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

What is your smartlock light doing?

Is it flashing fast or normal?

Does it go out when you turn the key to reds?
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sat Feb 14, 2015 9:36 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 5

Joined: 30th Jan 2015

Ride: EB Falcon

Location: Auckland
New Zealand

where is it?

didnt notice any light
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sat Feb 14, 2015 10:57 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Does your interior light work?

While holding the key to start, bump the dash firmly just above the handbrake?

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sun Feb 15, 2015 7:09 am 
Fordmods Newbie
Offline

Age: 29

Posts: 5

Joined: 30th Jan 2015

Ride: EB Falcon

Location: Auckland
New Zealand

thanks forgot to mention i have taken the BCM out and re soldered it
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sun Feb 15, 2015 8:56 am 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Going to answer my questions?

The bem won't be the problem... If anything is acting up it'll be the smartlock module...they don't get a hot joint, the common problem is one of the relays fail on the board...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sun Feb 15, 2015 9:17 am 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

scoot888 wrote:
thanks forgot to mention i have taken the BCM out and re soldered it


Smartlock is a seperate module in the EB/ED, not part of the BCM, unlike the EF/EL.
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sun Feb 15, 2015 1:49 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 5

Joined: 30th Jan 2015

Ride: EB Falcon

Location: Auckland
New Zealand

TimmyA wrote:
Going to answer my questions?

The bem won't be the problem... If anything is acting up it'll be the smartlock module...they don't get a hot joint, the common problem is one of the relays fail on the board...

Cheers,
Tim



sorry mate and no the interior light doesnt work
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Sun Feb 15, 2015 7:02 pm 
Technical Contributor
Offline

Posts: 492

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

check interior light circuit as mentioned by TimmyA - (fuse ?) as this powers smartlock system
Top
 Profile  
 
 
 Post subject: Re: ED Falcon wont start
Posted: Mon Feb 16, 2015 8:24 am 
Fordmods Newbie
Offline

Age: 29

Posts: 5

Joined: 30th Jan 2015

Ride: EB Falcon

Location: Auckland
New Zealand

TedW wrote:
check interior light circuit as mentioned by TimmyA - (fuse ?) as this powers smartlock system


thanks guys will check it today
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 6:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names