Fordmods Logo

ED V8 (AU III XR8 motor) cutting out 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: ED V8 (AU III XR8 motor) cutting out
Posted: Fri May 10, 2013 7:40 pm 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Hi chaps,

I have just picked up a pretty mickey mouse ED V8 Sprint Mock Up with an AUIII XR8 220 windsor in it. ( It was a good price and I didn't really want to pay top dollar to get an original sprint which I am going to start modifying anyway).

The car is awesome, apart from an issue with the electrics......

While driving along, it seems to lose electrics all of a sudden. Engine cuts out and loses all dash lights etc.

This can happen as a complete shut down requiring a restart or it just drops out and then continues to run after just a moment.

Not ideal and about the only falling down of the car..... Any suggestions??

I'm thinking possible ignition switch or BEM issue, but are there any other things I should check first?????

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
 Post subject: Re: ED V8 (AU III XR8 motor) cutting out
Posted: Sun Jun 16, 2013 8:36 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 4th Jun 2013

Ride: Ford Fairlane

Location: Cooyar
QLD, Australia

I had the same problem with my NC V8 so I changed the fuel filter and it fixed the problem
Top
 Profile  
 
 
 Post subject: Re: ED V8 (AU III XR8 motor) cutting out
Posted: Sun Jul 21, 2013 3:47 pm 
Oompa Loompa
Offline

Age: 42

Posts: 27

Joined: 23rd Feb 2012

Gallery: 10 images

Ride: 1997 EL XR8

Location: Northern Beaches, Sydney
NSW, Australia

I have the same problem in my el xr8. Allan, I can't work out how a fuel filter affects the electrics

 

_________________

No Officer, I don't know any better.

We can't stop here, it's bat country.

Top
 Profile  
 
 
 Post subject: Re: ED V8 (AU III XR8 motor) cutting out
Posted: Sun Jul 21, 2013 4:25 pm 
Getting Side Ways
Offline

Age: 29

Posts: 546

Joined: 5th Jun 2010

Ride: BA XT, NCII V8

Location: Adelaide
SA, Australia

lol had same issue with my NC V8 found it was the battery was not tied down would move and as the NC has a long low bonnet the positive terminal was hitting the bonnet. battery clamp and fixed
Top
 Profile  
 
 
 Post subject: Re: ED V8 (AU III XR8 motor) cutting out
Posted: Sun Jul 28, 2013 9:22 am 
Oompa Loompa
Offline

Age: 42

Posts: 27

Joined: 23rd Feb 2012

Gallery: 10 images

Ride: 1997 EL XR8

Location: Northern Beaches, Sydney
NSW, Australia

My battery is secure and it's posts are covered so it can't be the battery hitting my bonnet.

 

_________________

No Officer, I don't know any better.

We can't stop here, it's bat country.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names