Fordmods Logo

ef falcon alternator not charging at idle 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: ef falcon alternator not charging at idle
Posted: Mon Mar 23, 2015 11:19 am 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 78

Joined: 20th Jul 2011

Ride: ba fairlane ghia

Location: loftus
NSW, Australia

Hi all,
I have an ef futura charging at 12.5 v at idle and a bit higher on acceleration replaced tha alternator last night it was charging at 14.10v all loads on drove about 2 km and started charging at 12.5 loads on just head lights and radio help please
Top
 Profile  
 
 
 Post subject: Re: ef falcon alternator not charging at idle
Posted: Mon Mar 23, 2015 12:46 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Replaced a new alternator so you know that the second one hasn't failed too?

Bad Electrical connection between the alternator and block?
Bad main earth connection between the block, chassis and battery?
Bad connection on excitation supply wire?

Is your power steering leaking into the alternator causing it to fail? If replaced with a second hand one was that happening to it causing it to fail?

Power steering high pressure nut leaks must be fixed pronto to avoid alternator failure...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: ef falcon alternator not charging at idle
Posted: Fri Mar 27, 2015 11:46 am 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 78

Joined: 20th Jul 2011

Ride: ba fairlane ghia

Location: loftus
NSW, Australia

TimmyA wrote:
Replaced a new alternator so you know that the second one hasn't failed too?

Bad Electrical connection between the alternator and block?
Bad main earth connection between the block, chassis and battery?
Bad connection on excitation supply wire?

Is your power steering leaking into the alternator causing it to fail? If replaced with a second hand one was that happening to it causing it to fail?

Power steering high pressure nut leaks must be fixed pronto to avoid alternator failure...

Cheers,
Tim

Found problem oil on belt due to ps pump bolt hole in front
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 10:41 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names