Fordmods Logo

EF Falcon Rear Demister not connected? 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EF Falcon Rear Demister not connected?
Posted: Mon Apr 16, 2012 6:28 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 4

Joined: 24th Mar 2012

Ride: 1995 EF Falcon Gli Sedan

Location: Melbourne
VIC, Australia

Hi guys. I've got a White EF Model Falcon.

It's in need of a bit of work, the front windows on both sides are slighty damaged(tough to wind down and up), the Driver side needs a bit of lubricant, and after a break in(bastards stole my GPS) and subsiquent repair the passenger side window unseats from the right groove when winding back up(so it's best not to wind it down), The rear boot springs have gone and I may replace them soon.

Engine runs fine, battery connectors need to be cleaned(sometimes it takes a good push down on the battery connections before the car stays running after ignition). Anyway after the break-in I recently had a Car Alarm and also Car Stereo installed. I was informed of the issue this car has with it's factory speaker design(the cable connection is uncovered and can come loose) but that did give me the s**t for a bit till they told me it was a common issue with that Falcon.

However I've recently noticed the rear demister isn't working(the button won't go down and stay down like it should, and the globe doesn't light up). I believe they cut the power to the button(they may have told me about it, but I don't know, I seem to recall using it after the install was done) OR the button has worn out(most likely) OR the globe in the dash has gone(also possible, but I can't feel the button stay down, so thats probably not the issue)?

How can I get it fixed?

I'm really worried they actually cut the power to it(during the installation of the alarm as the LED has been placed above the demister button), because obviously I will need it.

I'm going to ask my mechanic for his opinion when I get the car serviced on friday.
Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Mon Apr 16, 2012 6:44 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

The demister button is a momentary switch. As in, it's not meant to stay down. Check your demister fuse. The demister warning lamp gets power from there as well.

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 8:56 am 
Fordmods Newbie
Offline

Age: 33

Posts: 4

Joined: 24th Mar 2012

Ride: 1995 EF Falcon Gli Sedan

Location: Melbourne
VIC, Australia

evxr6 wrote:
The demister button is a momentary switch. As in, it's not meant to stay down. Check your demister fuse. The demister warning lamp gets power from there as well.


Actually it does stay down(but not all the way down, just slightly lower than if it's off), I've noticed it before. The button locks into an on position, and you press it again to release it to switch the system off. This is the 1995 EF Gli base-model.
Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 10:35 am 
Fordmods Newbie
Offline

Age: 33

Posts: 4

Joined: 24th Mar 2012

Ride: 1995 EF Falcon Gli Sedan

Location: Melbourne
VIC, Australia

evxr6 wrote:
The demister button is a momentary switch. As in, it's not meant to stay down. Check your demister fuse. The demister warning lamp gets power from there as well.


yep, it's not the fuse, or at least it hasn't blown(still looks good). Might try a new one anyway just to see if that helps.

It's almost certainly a worn sensor on the actual button(after all it is more than 17 years old now), or the button has been disconnected.

I hope it's the latter as the former is probably more difficult to repair. To put it more clearly for you, as I wasn't clear last time, there's NO RESISTANCE on the button and it doesn't lock-in anymore like it used to, which a Computer and Gaming geek like myself would realise that means the Button itself may need to be repaired as it's not triggering the sensor(and may have been just plain disconnected)! In fact right now I'm having a simular problem with a Right Shoulder button on my Nintendo 3DS(but that's solved alot cheaper, by a compressed air blast right to the base of it)! Obviously it was probably done during the alarm installation(as they removed the cover and drilled a hole right above the button to put the Alarm LED in), potentially delibratly, and he may have even told me about it.

Even after these problems however I would still suggest someone get an Alarm installed, as the actual Alarm works brilliantly so far.
Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 11:12 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

If it's stuffed let me know, I've got a spare one you can have for the cost of postage. From memory the globe needs replacing, however I may be able to find a working globe in my box of goodies.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 12:36 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Get a piece of jumper wire, and momentary short the demister plug.
Should hear the relay click in the fuse box.
Check the rear window is getting warm after a few minutes.

All this is done with ACC power on of course.

Just get a 2nd hand switch if needed - there's on a million of them out there.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 1:03 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Regarding your passenger window.

Pull the door trim off and have a look at the glass panel holder. It may be loose and not holding the glass properly causing it to shift on the way up (more resistant on the rear of the glass causing glass to tilt pushing the front out). It could also be because whoever installed the glass, didn't slip it into the groove properly so doesn't guide the window properly.

If you need a hand with it let me know. Can have a look at it.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 1:17 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

colliric wrote:

However I've recently noticed the rear demister isn't working(the button won't go down and stay down like it should, and the globe doesn't light up). I believe they cut the power to the button(they may have told me about it, but I don't know, I seem to recall using it after the install was done) OR the button has worn out(most likely) OR the globe in the dash has gone(also possible, but I can't feel the button stay down, so thats probably not the issue)?

How can I get it fixed?


If you have never removed the dash surround before, have a read through THIS. (1st 2 paragraphs cover removing the surround, and you'll only need the 2 phillips head screwdrivers.) It covers how to remove the surround as well as the cluster, but the information you need to access the back of the switch and wiring etc is in there.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: EF Falcon Rear Demister not connected?
Posted: Tue Apr 17, 2012 9:15 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 4

Joined: 24th Mar 2012

Ride: 1995 EF Falcon Gli Sedan

Location: Melbourne
VIC, Australia

phongus wrote:
Regarding your passenger window.

Pull the door trim off and have a look at the glass panel holder. It may be loose and not holding the glass properly causing it to shift on the way up (more resistant on the rear of the glass causing glass to tilt pushing the front out). It could also be because whoever installed the glass, didn't slip it into the groove properly so doesn't guide the window properly.

If you need a hand with it let me know. Can have a look at it.


When they broke into the car, they damaged the frame(bent the metal a little), it's fixable but I'm probably just going to leave it. It goes properly halfway up, but then gets really hard once you get to that damaged bit. Glass panel holder is fine.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 1:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names