Fordmods Logo

EL Climate control panel 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL Climate control panel
Posted: Sun Dec 29, 2013 12:00 pm 
Fordmods Newbie
Offline

Age: 63

Posts: 2

Joined: 28th Dec 2013

Ride: EL Ford Station Wagon

Location: Newcastle
NSW, Australia

Can somebody help me with info relating to my EL LED climate control display going on & off at the moment it hasn't come on for some time it's annoying as you cannot operate any thing with it off. I have removed the dash & checked for loose wiring but everything seems to be OK.
Top
 Profile  
 
 
 Post subject: Re: EL Climate control panel
Posted: Sun Dec 29, 2013 1:43 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Have you checked the display globe?
Top
 Profile  
 
 
 Post subject: Re: EL Climate control panel
Posted: Sun Dec 29, 2013 7:33 pm 
Oompa Loompa
Offline

Age: 48

Posts: 35

Joined: 24th Sep 2010

Gallery: 4 images

Ride: 98 Fairlane Concorde 4.0

Location: Sunshine Coast
QLD, Australia

If you adjust the fan speed, does the speed change? I know you cant see it, but you should be able to hear it. Try other functions and see if they change the relevant feature. Might help you tell if its just display, or something more involved like the actual unit or wiring etc. They are buyable second hand on ebay fairly regularly, although I have no idea how often they die.

 

_________________

Silver NL Fairlane Concorde 98 4.0

1978 XC Fairmont GXL Update 5.8 with 218 Cam @ 50

Top
 Profile  
 
 
 Post subject: Re: EL Climate control panel
Posted: Mon Dec 30, 2013 9:17 am 
Fordmods Newbie
Offline

Age: 63

Posts: 2

Joined: 28th Dec 2013

Ride: EL Ford Station Wagon

Location: Newcastle
NSW, Australia

Thanks for the help fellas. When the LCD screen goes blank nothing will work you have no control over anything that the unit controls such as the fan speed, temp, vent etc. I just drove from Newcastle to Port Macquarie half way up it started again & when I stopped the car & started again it was blank again. Could be a dry joint in the unit I am sure there is no bulb it is a LCD display.
Top
 Profile  
 
 
 Post subject: Re: EL Climate control panel
Posted: Mon Dec 30, 2013 9:44 am 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

More than likely a dry joint in the CC unit. And yes there is a bulb (about 3 in the unit).

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 11:57 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names