Fordmods Logo

EL FUTURA starting problems 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: EL FUTURA starting problems
Posted: Mon Jul 01, 2013 9:51 pm 
Fordmods Newbie
Offline

Age: 61

Posts: 11

Joined: 22nd Sep 2012

Ride: EL Futura

Location: Melbourne
VIC, Australia

Just started having this problem, insert key and turn, absolutely nothing, no cranking, no start. Has happened a couple of times and when I go back several hours later, it starts ok. Tried spraying some silicon/WD40 into ignition lock. Don't know if that helped. Tried today and had nothing on the first 3 attempts, then it started ok. Any ideas?
Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Mon Jul 01, 2013 10:41 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Dry joint in the BEM.
Try this and if it works, that's the problem.
Turn and hold the key over to the Start position, then give the lower dash just above your left knee (light grey part pretty much right below the fuel gauge) a firm thump. If she kicks over you'll need to replace the BEM. Do a search on here for BEM or BCM for more info.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Mon Jul 01, 2013 10:45 pm 
Fordmods Newbie
Offline

Age: 61

Posts: 11

Joined: 22nd Sep 2012

Ride: EL Futura

Location: Melbourne
VIC, Australia

thanks, I'll have a go
Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Wed Jul 03, 2013 10:11 am 
Fordmods Newbie
Offline

Age: 61

Posts: 11

Joined: 22nd Sep 2012

Ride: EL Futura

Location: Melbourne
VIC, Australia

thanks for that tip, worked a treat, onto BEM replacement now, thanks again
Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Wed Jul 03, 2013 11:49 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

No problem mate.
It's a fairly common issue with the EF/L series. I'm on my 3rd BEM now.. :-)
Not sure if you've found out more about them but the EF and EL bems are NOT interchangeable, so you'll need to find an EL futura or xr one as they are the mid spec, the fairmont/lane ones have a different connector and wont fit without hacking the wiring up. In a pinch you can use a gli one but you'll lose some features like variable wiper speed and interior lighting fade wben you close the doors.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Wed Jul 03, 2013 2:01 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

HERE is a link to the BEM tech doc. Lot's of good info on the differences here, I couldn't link it before as I was using my phone.
You'll need to remove the fascia around the cluster to get at the top connector and retaining bolts, if you don't have a workshop manual THIS thread of mine will show you how the fascia comes off. There is no need to remove the cluster to get to the BEM.. but while you're there it's a good opportunity to replace any blown globes in the cluster, or do the backlight mod :)

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: EL FUTURA starting problems
Posted: Wed Jul 03, 2013 6:40 pm 
Fordmods Newbie
Offline

Age: 61

Posts: 11

Joined: 22nd Sep 2012

Ride: EL Futura

Location: Melbourne
VIC, Australia

thanks mate, really good info, much appreciated.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names