Fordmods Logo

EL Instruments Going Crazy 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: EL Instruments Going Crazy
Posted: Sat Nov 17, 2012 8:11 pm 
Fordmods Newbie
Offline

Age: 50

Posts: 4

Joined: 17th Sep 2005

Ride: EBII

Location: Coffs Harbour
NSW, Australia

hi i have a very strange prob with the wifes el fairmont which started last night

when car starts all gauges work warning lights are off as per normal then the volt meter climbs to top and falls and all warning lights come on, some flashing and the tacho temp oil volt and fuel gauge needles drop to zero and the odometer display goes off, the cluster appears dead apart from the warning lights, turn it off and back on the same happens again, this happens within a few seconds of starting it....the car otherwise drives fine.

i think it has also caused the headlamp bulbs to blow, i replaced the left one today that was blown yesterday when this started only to have the right globe blow when i tested the left one i had just replaced.....too much current for the bulbs?

to my limited knowledge on electrical things it seems to be getting a volt spike which causes everything else, could it be a regulator/relay??

where to look first? appreciate any replies
Top
 Profile  
 
 
 Post subject: Re: EL Instruments Going Crazy
Posted: Sat Nov 17, 2012 8:47 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

I'd be checkign the charging voltage.

Sounds like the regulator is playing up.

If you don't have a multimeter, simple unbolt the alternator +v post and tape up the wire so it doesn't earth out and take it around the block. Dont go far as your running on batteries only and themo fans drink a lot.

otherwise go the othe local do it yourself wreckers and spend the $25 and throw in a complete second hand alternator.
chances are its the cluprit.

also while your at it, a common problem for alternators to fail is:
leaking power steering pump.
leaking water pump plumbing (2 at the back) that sprays water onto the alternator.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: EL Instruments Going Crazy
Posted: Sat Nov 17, 2012 9:16 pm 
Fordmods Newbie
Offline

Age: 50

Posts: 4

Joined: 17th Sep 2005

Ride: EBII

Location: Coffs Harbour
NSW, Australia

Krytox

you are spot on sir

just pulled the wires off and went for a run.....every things working as it should

also while pulling said wires i noted a power steer pipe is weeping all over said alternator

thanks man saved me a trip to the sparkies
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:20 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names