Fordmods Logo

EL XR odometer not lighting in EL Sapphire 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: EL XR odometer not lighting in EL Sapphire
Posted: Sat Mar 30, 2013 9:53 pm 
Oompa Loompa
Offline

Age: 29

Posts: 36

Joined: 4th Oct 2011

Ride: 98 EL Falcon

Location: Mackay
QLD, Australia

So my build is just about done, I've put a XR dash cluster into my EL Sapphire, swapped some globes over to LEDs (I managed to get even coverage too!) I only swapped the ones that show up the main gauges and I can't seem to get my odometer to come on? (Still a standard globe) Is this normal? Any ideas? Everything else is lighting up fine.
Top
 Profile  
 
 
 Post subject: Re: EL XR odometer not lighting in EL Sapphire
Posted: Mon Apr 01, 2013 5:49 pm 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

Have you tested the globe to be sure it is working ? They are on all the time the car is running, so will fail before any others normally. The next trap is you may need to fit a resistor, this is only when you put the lights on and the Odo goes out. There is a tech doc about this, the high end models have a different body computer which remember the variable brightness settings. It should still work when you turn the engine on though. If the globe is OK, there may be a damaged socket, some were integral with the globe, swap it with another working one and see if the fault stays. If it does there may be some damage to the cluster like a broken track.

Regards 96ELGli

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: EL XR odometer not lighting in EL Sapphire
Posted: Fri Apr 12, 2013 10:17 pm 
Oompa Loompa
Offline

Age: 29

Posts: 36

Joined: 4th Oct 2011

Ride: 98 EL Falcon

Location: Mackay
QLD, Australia

Thanks for that it ended up being a faulty cluster so I swapped the face plates, needles and LED's over, soldered on a resistor, changed the LCD colour and it works a treat! My next task is trying to figure out how to get to the bulbs behind the buttons on the standard EF/EL aircon control...and in the demister switch...and what bulbs I will need and how to go about it...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 8:41 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names