Fordmods Logo

FG XT '08 - Aircon Fan Blower not working 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: FG XT '08 - Aircon Fan Blower not working
Posted: Sat Nov 15, 2014 11:04 am 
Fordmods Newbie
Offline

Age: 29

Posts: 1

Joined: 15th Nov 2014

Ride: FG XT '08

Location: Canberra
ACT, Australia

G'day,

Struck a weird problem with my XT FG, the Aircon is cooling perfectly fine (can tell when the vents are open, blowing air through).

However the Fan could be set to max, no movement whatsoever. I can hear the HIM module moving about when the Fan is switched on, but no dice.

Checked the filter (minimal lint/dust) behind the glove box and the Fan spins freely (not seized).

All my fuses are fine, both Interior and Engine Bays checked.

Suggestions by word-of-mouth have been replacing the Fans motor. Just wanted to see if anyone had any advice to offer, thanks in advance.

Azza.
Top
 Profile  
 
 
 Post subject: Re: FG XT '08 - Aircon Fan Blower not working
Posted: Sat Nov 15, 2014 7:00 pm 
Technical Contributor
Offline

Posts: 492

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

check fuse f26 under bonnet - disconnect fan motor plug and check for power and earth (ignition and fan turned on) - if both present try reconnect fan and tap motor lightly -if earth not present may have faulty HIM - check connection into HIM module - scan for codes -
if no power check connections back to fuse f26
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 2:35 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names