Fordmods Logo

Ford Falcon BA 2004 Sedan - No Instrument Cluster Lights 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: Ford Falcon BA 2004 Sedan - No Instrument Cluster Lights
Posted: Sat Mar 11, 2017 6:58 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 1

Joined: 11th Mar 2017

Ride: Ford/Falcon BA 2004

Location: Adelaide
SA, Australia

Hi guys,

I have seen numerous old threads in relation to my issue and have tried many of the ideas provided.
However my problem still persists and I was hoping someone may have other ideas.

Now, by instrument cluster I just mean the main guages as all the other surrounding lights work such as engine lights, indicator lights and so forth.

I have tested fuses.
I have pulled the wheel off to get to the wiring of the stalks and have no broken/split wiring.
I have even pulled the instrument panel out and checked the button for the dimmer switch.

However my problem is still there. Anyone have any more ideas?

I would take it to an Auto Elec but can't cover the cost at this stage.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 17, 2018 12:08 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names