Fordmods Logo

ICC Problem please help! 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: ICC Problem please help!
Posted: Fri Apr 21, 2017 6:16 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 1

Joined: 21st Apr 2017

Ride: BA xr6

Location: Sydney, Australia
NSW, Australia

BA xr6, ICC lights up (not the screen) but dosen't work, pulled apart the panels to get to it and unplugged the ICC from underneath and it turned on then turned itself back off after a day

Does this sound like the ICC is stuffed?
Top
 Profile  
 
 
 Post subject: Re: ICC Problem please help!
Posted: Sat Apr 22, 2017 10:34 pm 
Technical Contributor
Offline

Posts: 477

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

does anything work - heater fan -vent controls -radio etc. or nothing
connection for ICC is at rear when ICC is removed from dash- connections underneath are for BEM module-
is it working but in night mode -to change push and hold power button
if you remove ICC make sure you reset connector plug at rear by pulling toward you "slightly" until it locks
do reverse lights work -
try removing and refitting reverse fuse
check all fuses with a test light
have you had it scanned for codes
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Jul 26, 2017 5:53 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names