Fordmods Logo

LED TAIL LIGHTS IN BA, do I need load resistors? 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: LED TAIL LIGHTS IN BA, do I need load resistors?
Posted: Mon Nov 03, 2014 9:13 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

I know its probably been asked before and I know its the case in the au series but do I need load resistors in the BA to BF for led tail lights and what will be the side effects other than cruise not working? Thanks in advance

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: LED TAIL LIGHTS IN BA, do I need load resistors?
Posted: Mon Nov 03, 2014 9:50 pm 
Technical Contributor
Offline

Posts: 492

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

load resistors are required -cruise inop - flasher speed affected - globe fail warning active depending on vehicle level
Top
 Profile  
 
 
 Post subject: Re: LED TAIL LIGHTS IN BA, do I need load resistors?
Posted: Thu Nov 13, 2014 5:23 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

Turned out the lights came with looms and works fine

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 9:36 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names