Fordmods Logo

no high beams, no wipers 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: no high beams, no wipers
Posted: Fri Oct 18, 2013 11:16 pm 
Stock as a Rock
Offline

Age: 25

Posts: 191

Joined: 30th Dec 2010

Gallery: 2 images

Ride: Ford Falcon EA

Location: Ballarat
VIC, Australia

hey guys my cars wiper fuse blows everytime I turn the ignition on even if im not trying to use my wipers, and ive noticed I have no high beams but I can hear it clicking near the light when I try to flash my highs,

thanks guys
Top
 Profile  
 
 
 Post subject: Re: no high beams, no wipers
Posted: Sat Oct 19, 2013 8:30 am 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

If you have low beams the circuit breaker is ok and isn't full of corrosion yet... If the relay clicks then it's either a buggered relay, 2 blown globes, or broken wiring between the relay and the headlights...

Check those three...

Seems weird with the fuse... What model car and what has been added wiring wise? Most factory cars never short a fuse with the exception of the air bag fuse... Most blown fuses come from wiring that's been added and has been poorly done... Some cars I've seen... Esp driving lights and head units, it's no wonder why more cars don't catch fire and burn to the ground...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: no high beams, no wipers
Posted: Sat Oct 19, 2013 12:57 pm 
Stock as a Rock
Offline

Age: 25

Posts: 191

Joined: 30th Dec 2010

Gallery: 2 images

Ride: Ford Falcon EA

Location: Ballarat
VIC, Australia

its a 88 ea spac, nothing different has been added since last time it was on the road, before it was put off the road it was fine, I had wipers and high beams but now theres nothing and I reckon ive gone through 10 15a fuses trying different types of things to fix it, if I disconnect the loom in the engine bay for the wiper motor then I check the volts in the fuse clip it reads 9. but with it connected it reads 0 unless I turn the ignition on it will read 12
Top
 Profile  
 
 
 Post subject: Re: no high beams, no wipers
Posted: Sat Oct 19, 2013 1:41 pm 
Stock as a Rock
Offline

Age: 25

Posts: 191

Joined: 30th Dec 2010

Gallery: 2 images

Ride: Ford Falcon EA

Location: Ballarat
VIC, Australia

so I just had a look at the relays near the battery, and nothing looked out of the ordinary so I sprayed some contact cleaner on the wire terminals and the fusable links that I could see and now my high beams work but I still have the issue with the wiper fuse blowing. any chance you could tell me what relay works the low and high beams
thanks.
Top
 Profile  
 
 
 Post subject: Re: no high beams, no wipers
Posted: Thu Mar 27, 2014 11:07 am 
Oompa Loompa
Offline
User avatar

Age: 30

Posts: 22

Joined: 8th Feb 2006

Gallery: 3 images

Ride: Falcon XF

Location: Adelaide
SA, Australia

I'm just gonna bump this thread because I have the exact same issue in EB Ghia. No High beams and Wiper fuse blows every time ignition is turned on. Disconnected Wiper motor and combo switch and the fuse still blows, so obviously fault is elsewhere.

 

_________________

Projects on the Go:

1981 351 XD Fairmont
2004 BAII XR6 Turbo

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 10:48 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names