Fordmods Logo

oil pressure guage not reading 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: oil pressure guage not reading
Posted: Fri Sep 22, 2017 7:10 am 
Fordmods Newbie
Offline

Age: 62

Posts: 17

Joined: 7th Jan 2014

Ride: au falcon

Location: sydney
NSW, Australia

hello everybody, I recently converted my au 1 falcon trayback interior to a series 2 ghia with a woodgrain dash all the wiring from the donor car has been used complete including the engine bay harness the car starts and runs but the oil pressure guage wont read and the low oil light and warning beeps come on I did read you needed to change the orginal oil pressure switch on the engine to a sensor type which I have done but a poster on another forum has advised I should have left the original sender in there so I am not sure what to do now Could anybody please let me know thanks
Top
 Profile  
 
 
 Post subject: Re: oil pressure guage not reading
Posted: Fri Sep 22, 2017 6:59 pm 
Fordmods Junkie
Online
User avatar

Posts: 2698

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

if the cluster ya using has a separate oil gauge .. you need the oil pressure unit. if you don't have an oil gauge in cluster you need the idiot light sender. if it does have a gauge & ya using a pressure sender it "maybe" the wrong type of pressure sender? [as in EA-ED used a different unit to the later models] ... i'd check with me AU1 Fairmont but canna be bothered drivin ove to mates and looking :roll:
Top
 Profile  
 
 
 Post subject: Re: oil pressure guage not reading
Posted: Fri Sep 22, 2017 7:42 pm 
Fordmods Newbie
Offline

Age: 62

Posts: 17

Joined: 7th Jan 2014

Ride: au falcon

Location: sydney
NSW, Australia

far out thats confusing lol The dash I have is the woodgrain ghia dash with a oil pressure gauge in it if that helps it is out of a au series 2 the engine is my orginal dedicated gas series 1 so when you get a chance what do you think I need to do ....Thanks mate for your response just reading your post I bought a pressure sender from ford to replace the light sender in the existing motor it was ment for an au maybe they gave me the wrong one who knows !!!!
Top
 Profile  
 
 
 Post subject: Re: oil pressure guage not reading
Posted: Fri Sep 22, 2017 8:19 pm 
Fordmods Junkie
Online
User avatar

Posts: 2698

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Oct 17, 2017 8:23 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names