Fordmods Logo

radio, wipers elec mirrors not working 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: radio, wipers elec mirrors not working
Posted: Tue Nov 26, 2013 11:50 pm 
Oompa Loompa
Offline

Age: 22

Posts: 40

Joined: 5th Oct 2013

Ride: ED GLi

Location: Adelaide
SA, Australia

Hey guys

Today I noticed that I couldn't get my radio to come on (aftermarket one). By chance I discovered that my mirrors would not work either, along with my rear demister and wipers. WTF is going on here???? I read something about the relay behind the handbrake (grey box) as being the possible problem, plugged it in again and no change.

Anyone else have this problem before? Anyone know what is wrong? I'd appreciate any help I can get :)
Top
 Profile  
 
 
 Post subject: Re: radio, wipers elec mirrors not working
Posted: Wed Nov 27, 2013 12:02 am 
Stock as a Rock
Offline
User avatar

Age: 23

Posts: 151

Joined: 13th Jun 2012

Ride: Fairmont AU I

Location: Melton, vic
VIC, Australia

check all your fuses?
Top
 Profile  
 
 
 Post subject: Re: radio, wipers elec mirrors not working
Posted: Wed Nov 27, 2013 6:50 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Possibly the ignition switch too. My car does this - that circuit is disabled on "start" and supposed to come back on when the key goes back to on. On my car this is intermittent

Nigel
Top
 Profile  
 
 
 Post subject: Re: radio, wipers elec mirrors not working
Posted: Fri Nov 29, 2013 2:17 pm 
Oompa Loompa
Offline

Age: 22

Posts: 40

Joined: 5th Oct 2013

Ride: ED GLi

Location: Adelaide
SA, Australia

Problem solved, turns out I skipped the rear defog fuse when I was checking the fuses the other day.

CHECK YO FUSES PROPERLY
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 1:51 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names