Fordmods Logo

Replaced combination stalk, now jets not spraying - BF MK2 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Replaced combination stalk, now jets not spraying - BF MK2
Posted: Mon Dec 04, 2017 4:21 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 4th Dec 2017

Ride: Ford Falcon BF MK II

Location: Melbourne
WA, Australia

Hi All,
Recently, due to faulty wiring, I was forced to replace the combination stalk on my BF MK2 ES Falcon.
I purchased the new stalk from a breakers yard but it wasn't until after i'd fitted it that i realised there was an extra twisting dial switch on the end of the wiper stalk which is supposed to control a rear wiper and jet which my vehicle does not have.
The front wipers, including the intermittent, work fine however the front jets do not work now and i cannot hear the washer motor whiring away either.
My question is should the wiring be the same in the combination switch and the washer motor has just blown, or is the wiring different and should i buy the correct combo switch

Thanks in advance
Top
 Profile  
 
 
 Post subject: Re: Replaced combination stalk, now jets not spraying - BF MK2
Posted: Mon Dec 04, 2017 6:50 pm 
Tyre Shredder
Offline
User avatar

Age: 34

Posts: 322

Joined: 24th Jun 2014

Gallery: 4 images

Ride: BA XR6 Turbo

Location: Jamestown
SA, Australia

Shaeds wrote:
Hi All,
Recently, due to faulty wiring, I was forced to replace the combination stalk on my BF MK2 ES Falcon.
I purchased the new stalk from a breakers yard but it wasn't until after i'd fitted it that i realised there was an extra twisting dial switch on the end of the wiper stalk which is supposed to control a rear wiper and jet which my vehicle does not have.
The front wipers, including the intermittent, work fine however the front jets do not work now and i cannot hear the washer motor whiring away either.
My question is should the wiring be the same in the combination switch and the washer motor has just blown, or is the wiring different and should i buy the correct combo switch

Thanks in advance



Wiring i would assume to be the same just the extras for the wagon stuff in the back, was the washer pump working with the old stalk?

Might be worth unhooking the new stalk under the dash hooking the old one up and see if the pump works then, might be a brummy switch in the (new) stalk you got

 

_________________

Current Ride
BA XR6 Turbo, P3 Paint, BP Trim, Fully Stock Mods to Come!
1996 EF Falcon furura, White.
BA XR6 , P3 Paint, BG Trim, !
1995 EF XR6 The newest member of my ford family!

BLUE BLOOD
Previous Rides
1997 EL Falcon
1980 Ford Escort

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 10:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names