Fordmods Logo

Stereo, interior light and intermittent wipers not working 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Stereo, interior light and intermittent wipers not working
Posted: Wed Apr 13, 2016 7:58 pm 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 28

Joined: 6th Mar 2011

Gallery: 5 images

Ride: 4.0 DOHC EF Wagon

Location: Sunbury
VIC, Australia

Hey guys,

I had a good search and couldn't find a similar situation, so I guess I'll ask..

The other day out of the blue, my stereo, interior light and intermittent windscreen wiper setting stopped working. The other speeds for the wipers, cigarette lighter, fan etc all works, it's only the things I mentioned that aren't working.

My first thought was fuses of course, but they're all intact. What else could it be? Any thoughts?

Cheers!

 

_________________

White 1995 EF Wagon with Barra 182

Top
 Profile  
 
 
 Post subject: Re: Stereo, interior light and intermittent wipers not working
Posted: Thu Apr 14, 2016 2:05 pm 
Technical Contributor
Offline

Posts: 490

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

drummer.ash wrote:
Hey guys,

I had a good search and couldn't find a similar situation, so I guess I'll ask..

The other day out of the blue, my stereo, interior light and intermittent windscreen wiper setting stopped working. The other speeds for the wipers, cigarette lighter, fan etc all works, it's only the things I mentioned that aren't working.

My first thought was fuses of course, but they're all intact. What else could it be? Any thoughts?

Cheers!


suggest recheck all fuses with a test light,especially interior light & bem fuses-remove then refit BEM fuse...
possible faulty BEM module try disconnecting and reconnecting connector
check for power at interior light or glove box light -(battery saver circuit green/yellow wire).......
does radio show CODE and do you have the code ??
any work recently ??
Top
 Profile  
 
 
 Post subject: Re: Stereo, interior light and intermittent wipers not working
Posted: Tue Apr 19, 2016 6:01 pm 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 28

Joined: 6th Mar 2011

Gallery: 5 images

Ride: 4.0 DOHC EF Wagon

Location: Sunbury
VIC, Australia

You're a bloody genius. Tested them all with a multimeter and sure enough, one had an immeasurable amount of resistance, but hadn't blow. Turns out the terminals of the fuse had some sort of build up on them. Sanded the terminals and plugged it back in and it sprang to life!

Side question: any idea what the build up could be due to, besides age? It seemed like a mineral build up or something, not just dirt/grime.

Thanks a bunch!

 

_________________

White 1995 EF Wagon with Barra 182

Top
 Profile  
 
 
 Post subject: Re: Stereo, interior light and intermittent wipers not working
Posted: Wed Apr 20, 2016 9:31 am 
Fordmods Junkie
Offline
User avatar

Posts: 11723

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

drummer.ash wrote:
You're a bloody genius. Tested them all with a multimeter and sure enough, one had an immeasurable amount of resistance, but hadn't blow. Turns out the terminals of the fuse had some sort of build up on them. Sanded the terminals and plugged it back in and it sprang to life!

Side question: any idea what the build up could be due to, besides age? It seemed like a mineral build up or something, not just dirt/grime.

Thanks a bunch!


Just age. More time exposed to air, untreated metal will usually oxidise. Similar to untreated metal left out in the yard to rust. Add to that the dust/dirt that accumulates over time can cause issues.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Oct 20, 2017 2:25 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names