Fordmods Logo

xh falcon thermo fans 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: xh falcon thermo fans
Posted: Wed Jan 02, 2013 3:20 pm 
Oompa Loompa
Offline

Age: 32

Posts: 21

Joined: 27th Feb 2012

Ride: 5.0L eb fairmont ghia, xe ute

Location: gold coast
QLD, Australia

I have a problem with my the thermo fans not working on xh falcon ute I have checked the fans straight to the battery and they work I have also checked the wiring and fuses and they seem fine does anyone have any ideas your answers will be much appreciated
Top
 Profile  
 
 
 Post subject: Re: xh falcon thermo fans
Posted: Wed Jan 02, 2013 5:25 pm 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

I have an EL, there are a number of relays, and you may need to disconnect the battery. My Fans stopped running on high, and a reset of the ECU fixed it. If you do this, you will need to reset the radio code and retrain the remotes. I am thinking about changing the control circuits around, but there are some traps. A short term fix is get some connectors from a wrecker and wire a new relay and use a switch or a capillary switch to run them.

Regards 96ELGli

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: xh falcon thermo fans
Posted: Wed Jan 02, 2013 8:52 pm 
Oompa Loompa
Offline

Age: 32

Posts: 21

Joined: 27th Feb 2012

Ride: 5.0L eb fairmont ghia, xe ute

Location: gold coast
QLD, Australia

96ELGli wrote:
Hi,

I have an EL, there are a number of relays, and you may need to disconnect the battery. My Fans stopped running on high, and a reset of the ECU fixed it. If you do this, you will need to reset the radio code and retrain the remotes. I am thinking about changing the control circuits around, but there are some traps. A short term fix is get some connectors from a wrecker and wire a new relay and use a switch or a capillary switch to run them.

Regards 96ELGli

ok thanks mate i will give it a go
Top
 Profile  
 
 
 Post subject: Re: xh falcon thermo fans
Posted: Thu Jan 03, 2013 6:42 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

When you reset it, leave the battery lead off for at least 1/2 an hour. If you look at the resource Tab above there is info for some models to force the Fans to run. This will be handy for testing and fault finding. I am not sure if there is any specific info for your model, but hopefully another XH owner will comment. For the Temp. fix get part of the harness from a wrecker rather than hack up yours.

Regards 96ELGli

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: xh falcon thermo fans
Posted: Thu Jan 10, 2013 4:20 pm 
Oompa Loompa
Offline

Age: 32

Posts: 21

Joined: 27th Feb 2012

Ride: 5.0L eb fairmont ghia, xe ute

Location: gold coast
QLD, Australia

all good all fixed there was a dodgey connection between the yellow wire and the fuse
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 8:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names