Fordmods Logo

black exhaust smoke after instaling fuel presure reg 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: black exhaust smoke after instaling fuel presure reg
Posted: Mon Feb 28, 2011 1:19 am 
Parts Gopher
Offline

Age: 42

Posts: 82

Joined: 21st Feb 2010

Ride: FG XR6 TURBO

Location: BLACKTOWN
NSW, Australia

mate has a ef he just fitted a turbo to it has been fitted witha walbro 041 fuel pump and a obx 12.1 fuel reg car ran ok with pump fitted till he installed the fuel presure reg now it blows black smoke when idleing and soon as u rev the engine it idles back down and stalls also is fauling up the plug black soot on all six ..any ideas would be helpfull

 

_________________

BANNED

Top
 Profile  
 
 
 Post subject: Re: black exhaust smoke after instaling fuel presure reg
Posted: Mon Feb 28, 2011 7:38 am 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

Its obviously getting too much petrol, is the fuel reg too big? Is the return line that returns to the fuel tank blocked

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: black exhaust smoke after instaling fuel presure reg
Posted: Mon Feb 28, 2011 8:37 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

shane falcon futura wrote:
mate has a ef he just fitted a turbo to it has been fitted witha walbro 041 fuel pump and a obx 12.1 fuel reg car ran ok with pump fitted till he installed the fuel presure reg now it blows black smoke when idleing and soon as u rev the engine it idles back down and stalls also is fauling up the plug black soot on all six ..any ideas would be helpfull


its obviously getting to much fuel..
what size injectors are you running? are you running any j3 or aftermarket ecu??
Top
 Profile  
 
 
 Post subject: Re: black exhaust smoke after instaling fuel presure reg
Posted: Mon Feb 28, 2011 4:49 pm 
Getting Side Ways
Offline
User avatar

Posts: 1140

Joined: 27th Feb 2005

Ride: Supercharged EF Fairmont

Location: T.I. Performance HQ
VIC, Australia

He said he installed a 12:1 reg.

Fair chance you've installed it backwards :)
Top
 Profile  
 
 
 Post subject: Re: black exhaust smoke after instaling fuel presure reg
Posted: Thu Mar 03, 2011 1:39 am 
Parts Gopher
Offline

Age: 42

Posts: 82

Joined: 21st Feb 2010

Ride: FG XR6 TURBO

Location: BLACKTOWN
NSW, Australia

yeah turned the hoses around and made sure it returning fuel to the tank see if that works obx fuel regs dont have any markings in or out any way thanks for the info

 

_________________

BANNED

Top
 Profile  
 
 
 Post subject: Re: black exhaust smoke after instaling fuel presure reg
Posted: Thu Mar 10, 2011 1:00 am 
Parts Gopher
Offline

Age: 42

Posts: 82

Joined: 21st Feb 2010

Ride: FG XR6 TURBO

Location: BLACKTOWN
NSW, Australia

yeah just a up date on this thread changed the fuel lines around almost no black smoke.cause the car hasnt been on the road for a while will be carbon build up..

 

_________________

BANNED

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:50 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names