Fordmods Logo

Crow cam and HP4 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: Crow cam and HP4
Posted: Thu Nov 17, 2005 5:14 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

Hi All,

Well I bit the bullet last week and installed a crow stage 3 (2222549) cam and chiptorque HP4 chip into my EL.

Ok so the install went well (apart from a shattered timing chain tensioner) And some lifters that take ages (like 5 min) to stop ticking when starting from cold.

The idle with the chip is fine during warmup but when hot it's pretty poor. Like stalls when you turn the wheel etc. Anyone else had this problem. Seccondly throttle response is also really poor. It improves a little around 3000 RPM but its crap compared to std setup. It's idling at around 750 rpm with 15 inches of vac. at 2500 rpm, no load it's 21 inches vac.

Can this stuff be fixed with tuning or is it just the cam? I have the oppertunity to get the chip dynotuned in real time in 2 weeks. Just want to know what to ask for to fix driveability. Power is smooth and feels better from 2500 rpm up perhaps not as much as I was expecting though.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
Posted: Thu Nov 17, 2005 6:01 pm 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

At a very random guess, as I've got no experience with tuning, I'd say the cause of these problems will pop up when it's being dynoed, with AFR's being measured real time etc.
How much dyno time have you got Spork?
Also I'm assuming the Crow 'stage 3' is a fairly hardcore cam if it needs a chip to idle, your sig says Lukey zorst, and I vaguely remember your posts on Airbox mods, but what about extractors?
Might help opening it up a bit.

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Thu Nov 17, 2005 10:40 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

the 2549 should run with out the chip, it's only mild.


are you saying you fitted the chip and are expecting it to run right with out dyno tuning??

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
Posted: Fri Nov 18, 2005 8:09 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

I can say the 2549 definately did not run well at all without the chip. There was NO idle or anyting below 1000 RPM and black smoke came from the exhaust on part throttle.
I was told it would lean out on full throttle so I didn't try it.

Yeah I have extractors, airbox and intake mods, 2.5 exhaust, this cam and the chip.

Anyway to update the idle has almost fixed itself. I reset the ecu and secured the ignition leads so and it can idle now although it is 'lumpy'. Throttle response is still crap though.

Dyno time is only limited by my wallet! it's $200/hr + dyno fees. But since the chip is 90% right I am hoping that it will only take 1 & 1/2 hours. I just want full load checked and adjusted and then the idle and drivability fixed. Also removal of speed limiter.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
Posted: Sun Nov 20, 2005 8:13 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

As a followup the lifters have settled down. Apparently when you install new ones they take a while for the air to bleed out of them.

Car is running much better now. Idle is steady but shakes the car. Never stalls since I reset the ECU and cleaned the chip contacts.

Power wise the car does 10-100 in 7.2 sec without a launch (1000 rpm first gear) as opposed to 7.4 sec before. What this doesnt show is that there is heaps more power up high so it's definately faster when launching properly.

Other notes on power, I don't know why ppl quote "this cam is good from 1500 - 4400" becasue in reality below 2000 rpm there is a definate lack of torque, then to 2300 rpm its probabily the same as stock. After that it hauls a**! with peak torque probabily around 4500 RPM and it revs cleanly to the limiter with a new angry snarl from the exhaust.

Driveabiliy is still a bit off but it's better when cold so I think it is a tuning issue which will get sorted out when the car is tuned on the dyno.

Also checked knock sensor and O2 sensor and there is no more knock activity than standard and mixtures are as steady as a rock from 2000 RPM up.

I'm pretty damn happy with this mod but I would never do it without the chip. I mean the damn thing wouldn't idle AT ALL without the chip. And it's good knowing my mixtures and timing is safe + I can get it dyno tuned for that last 5%!

P.S. Turns out the crow site has a mistake, it lists the 2549 as EA-ED when it is actually for EF-EL also the specs on the sheet that came with the cam are different from the website.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
Posted: Mon Dec 19, 2005 12:46 am 
Getting Side Ways
Offline

Age: 33

Posts: 868

Joined: 23rd Sep 2005

Ride: eb falcon

Location: kadina
SA, Australia

they did change the 549 grind, i have the original grind, which varies to the one on the site, but very similar..

i also got the hp4 with mine, i got the kit, it was s**t when i got it, it wouldnt idle down from 2000rpm, i emailed chiptorque, never got a response, so i just disconnected my isc, and adjusted my idle using the throttle stop, had to hold the revs up for the first 30secs when cold, but other than that, it had a solid idle when warm...

 

_________________

EB 4L, 8.4:1, R154, GT4202r, 4in exhaust, Greenslade Engineering exhaust manifold, plenum chamber, 90mm throttle, Garrett W2A cooler, Surecam custom, autronic SM4, Bosch 120lb, Crane HI-6, LX-92, LM-1, Turbosmart Reg, 2x bosch 044, turbosmart 48 gate. 470kw+ @ 18PSI

Top
 Profile  
 
 
Posted: Mon Dec 19, 2005 1:00 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

An update from this.

Chiptorque gave me a free reflash to fix idle and power problems etc. Now it runs like a dream. Like factory + 30% more torque everywhere.
You should just give chiptorque a call they are really helpfull.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
Posted: Mon Dec 19, 2005 1:23 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2280

Joined: 5th Nov 2004

Ride: EF Falcon 95

Location: Rosebud
VIC, Australia

if the idle was shockin when u first put the cam in, thats normal, takes a while for the cam to bed into the computer, my idle was shockin when i first put the 1004 cam in, its fine now though, took bout a week for the car to get 100% used to it

 

_________________

Cougar Zero makes my pants fit nice.

Top
 Profile  
 
 
Posted: Mon Dec 19, 2005 2:23 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

The computer will learn to idle a 1004-114, but has a very tough time with anything wilder. With my old 1004-110 the idle was VERY lumpy, and the 1521a I have now will bearly idle with stock ecu.

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Tue Dec 20, 2005 7:44 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

Yeah, really you should always change the ECu when you are doing a cam, becasue these ecu's use manifold pressure to determine how much fuel to add. With a cam all the relationships between airflow through the engine and manifold pressure change signifcantly. So your ecu needs to be re-mapped to suit the new airflows.

Sure it can learn around idle but what affect does it have on the rest of the engine range? After the chip it made a massive difference to my car. Now my car has the same or better driveability idle etc. than factory everywhere. For $600 it made more difference than the exhaust or the cam (by itself) mods.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
Posted: Wed Dec 21, 2005 2:02 am 
Getting Side Ways
Offline

Age: 33

Posts: 868

Joined: 23rd Sep 2005

Ride: eb falcon

Location: kadina
SA, Australia

yea, probably should have chased it up further, but that was over 2 years ago, now have nearly finished my turbo setup, and are running the autronic sm4 ecu

 

_________________

EB 4L, 8.4:1, R154, GT4202r, 4in exhaust, Greenslade Engineering exhaust manifold, plenum chamber, 90mm throttle, Garrett W2A cooler, Surecam custom, autronic SM4, Bosch 120lb, Crane HI-6, LX-92, LM-1, Turbosmart Reg, 2x bosch 044, turbosmart 48 gate. 470kw+ @ 18PSI

Top
 Profile  
 
 
Posted: Sun Feb 25, 2007 9:46 pm 
Oompa Loompa
Offline

Posts: 21

Joined: 31st Aug 2005

Ride: au2 forte

Location: newcastle
NSW, Australia

What sort of power did you end up putting out spork?? post up a dyno sheet for us all to have a look at ;)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 9:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names