Fordmods Logo

DSC issues on my 06 BF XR6T 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: DSC issues on my 06 BF XR6T
Posted: Sat Jul 28, 2012 5:23 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 9th Apr 2012

Location: adelaide
SA, Australia

Guys, in desperate need of ideas on how to fix my car.
I’ll be driving along and for no reason the traction light will come on and stay on for no reason. Turn the car off and on and it goes out. Its starts off doing this once or twice a week, then slowly over the coming week it gets to the stage that 15 mins into any drive the light will come on and stay on. Pressing the button on and off makes no change, only thing that resets it is turning the car on and off. Have even tried physically turning the traction control off at the start of a drive, I then drive the car for 20 mins, go to turn the traction control on again and the light on the dash stays on.
On the most, the car will drive fine , it’s just that the light is on. But after a week or so of it coming on all the time, it seems that the DSC is tricked into thinking the car is out of control and Ive have had it kick in mid corner!!! There is a corner 200m from work that I do at 30km/hr whilst the car is cold that makes the DSC flip out every time!!! Like I said, it only does this after the light has been coming on for a week or so.

Now that I’ve explained the symptoms, he is what I’ve tried so far. Of course my first call was to Ford dealership, they scanned it and it said “steering angle sensor needs calibration”, so after paying my money, they re calibrate it and its fine for another 6 weeks. This went on 4 times, every time Ford had an excuse, first it was due for a wheel alignment, then it needed it cos I replaced the front end bushes, then it was cos I put wheels on it and they needed to put the new sizes into the ECU/ I coped it all on the chin, but everysingle time the outcome was the same.
Done, dusted, I had it recalibrated twice more after having changed nothing on the car at all, then 6 weeks ago, I took Fords advice and “next logical step” and replaced the steering angle sensor itself. Even tho the error is calling for it to be “recalibrated” and not actually faulty I thought, Ok lets do it.

Guess what happened today? The light came on again!!!
Whats my next step?

Edit: car is dead stock apart from wheels and intercooler upgrade
Top
 Profile  
 
 
 Post subject: Re: DSC issues on my 06 BF XR6T
Posted: Mon Oct 16, 2017 9:37 am 
Fordmods Newbie
Offline

Age: 28

Posts: 4

Joined: 12th Feb 2008

Ride: EF Xr6

Location: Melbourne
VIC, Australia

Hey mate did you ever end up fixing this concern? I have an 06 fairmont with the exact same story
Top
 Profile  
 
 
 Post subject: Re: DSC issues on my 06 BF XR6T
Posted: Mon Oct 16, 2017 3:42 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2752

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

powell_91 wrote:
Hey mate did you ever end up fixing this concern? I have an 06 fairmont with the exact same story



seeing as this is from 2012 .... and op only did one post . . . . I think not :mrgreen:
Top
 Profile  
 
 
 Post subject: Re: DSC issues on my 06 BF XR6T
Posted: Mon Oct 16, 2017 6:56 pm 
Tyre Shredder
Offline
User avatar

Age: 34

Posts: 322

Joined: 24th Jun 2014

Gallery: 4 images

Ride: BA XR6 Turbo

Location: Jamestown
SA, Australia

powell_91 wrote:
Hey mate did you ever end up fixing this concern? I have an 06 fairmont with the exact same story



Tyres all the same size and profile? too far out of size and profile makes them play up

 

_________________

Current Ride
BA XR6 Turbo, P3 Paint, BP Trim, Fully Stock Mods to Come!
1996 EF Falcon furura, White.
BA XR6 , P3 Paint, BG Trim, !
1995 EF XR6 The newest member of my ford family!

BLUE BLOOD
Previous Rides
1997 EL Falcon
1980 Ford Escort

Top
 Profile  
 
 
 Post subject: Re: DSC issues on my 06 BF XR6T
Posted: Mon Oct 16, 2017 7:01 pm 
Fordmods Newbie
Offline

Age: 28

Posts: 4

Joined: 12th Feb 2008

Ride: EF Xr6

Location: Melbourne
VIC, Australia

Yeah tyres and rims are all standard, it logs a fault code for the steering angle sensor which I have replaced before so I’m thinking it may be a problem in the abs module given that’s what the sas communicates with
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 4:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names